Search found 16 matches

by martin
11 Dec 2018, 16:30
Forum: General questions
Topic: Draw over a surface
Replies: 1
Views: 145

Draw over a surface

Hello, I am interested on being able to simulate "draw" over a surface, as it is presented at the beginning of your promotional video of 2014 (https://www.youtube.com/watch?v=gBYqOBdIcaY). What I want is something like that: simulate a robot draw over a surface and detect it by a vision sensor. I've...
by martin
23 Oct 2018, 17:38
Forum: Bug reports
Topic: Segfault on start-up in Ubuntu 18.04
Replies: 5
Views: 1962

Re: Segfault on start-up in Ubuntu 18.04

Hello,

I've found today the same issue, but installing what fabro and fferri posted here looks like it works for me. The user interface show sometimes strange behaviors, but the simulation seems to work properly.

Thanks for posting a solution.

Regards!
by martin
18 Dec 2017, 12:14
Forum: General questions
Topic: Strange behaviour among PCs and in the same PC
Replies: 5
Views: 727

Re: Strange behaviour among PCs and in the same PC

Hello Coppelia,

We do not have the real time mode enable. Our configurations settings are those that came from default. I supposse that if the computers are different, a simple program as I have post (without any type of calculation) would work similar in both PC in non-synchronous mode.

Regards!
by martin
12 Dec 2017, 17:31
Forum: General questions
Topic: Strange behaviour among PCs and in the same PC
Replies: 5
Views: 727

Re: Strange behaviour among PCs and in the same PC

Hello, What It happen is: I'm using a Python external API and I'm working wiht Python functions. The pseudocode I'm using is the following: for n in range (0, 4): returnCode, posicion_inicial = vrep.simxGetObjectPosition(clientID, carcasaHandler, -1, vrep.simx_opmode_buffer) targetVelocity = [-vel_i...
by martin
07 Dec 2017, 18:27
Forum: General questions
Topic: Strange behaviour among PCs and in the same PC
Replies: 5
Views: 727

Strange behaviour among PCs and in the same PC

Hello, A colleage and me are working on a project and we found a strange behaviour on VREP. We are running a mobile robot, we use revolute joints as motors. We control our mobile robot by the external Python API. We use the "simxSetJointTargetVelocity" function for moving the robot. In this context,...
by martin
07 Dec 2017, 18:15
Forum: General questions
Topic: Problem with remoteApi.dll
Replies: 3
Views: 964

Problem with remoteApi.dll

Hello, I've worked with VREP many times, and I still can do it. But now a colleague has started to use the VREP too and we've found a problem. We share a folder which we work on the same program. It consist of an VREP scene, and a Python project. We use the external Python API for controlling our ro...
by martin
01 Jul 2017, 18:22
Forum: General questions
Topic: Python external API question
Replies: 1
Views: 571

Python external API question

Hello, After working a little with the VREP, I have some issues I'd like to clarify. I'am working in a scene in synchronous mode. I think I spend too much time in a start o stop command. For testing this, I've written a simple program using the bubbleRobscene.ttt for testing the time between the sta...
by martin
14 Jun 2017, 21:06
Forum: General questions
Topic: python and vrep
Replies: 4
Views: 1842

Re: python and vrep

Hello wpc,

For starting with python and VREP communication, I recommend you this video tutorial:
https://www.youtube.com/watch?v=SQont-mTnfM

For me was very useful in a starting point.

Regards!
by martin
29 May 2017, 15:28
Forum: General questions
Topic: Problem with Stop command and reset scene
Replies: 2
Views: 4820

Re: Problem with Stop command and reset scene

Hello again, "when you stop a simulation, make sure to also stop streaming all data." Many thanks, that was very useful to me. Stopping the streaming data as it is mentioned here: http://www.forum.coppeliarobotics.com/viewtopic.php?f=5&t=1577&hilit=return+3&start=10 works for a "motor reset" and it ...
by martin
20 May 2017, 13:11
Forum: General questions
Topic: Python API Synchronization problem.
Replies: 2
Views: 5112

Re: Python API Synchronization problem.

Hello, I was able to find a solution to this problem. I've followed your suggestion to load an scene with the model in it instead of loading the model each time and I've followed your "step guide". But the problem was still there. To solve it, I have to finish a and start a new comunication with the...