Search found 6 matches

by jegovila
03 Sep 2013, 22:24
Forum: General questions
Topic: Sensor Image with C++
Replies: 1
Views: 1496

Sensor Image with C++

Hello I am trying to send an image from V-REP to C++. I am familiar with image processing in Matlab and I am trying to do something like that in C++, i.e. sending an image as a 2-D matrix and access to each pixel and its intensity (0-255). I saw the Api function "simxGetVisionSensorImage", and one o...
by jegovila
20 Jul 2013, 22:00
Forum: General questions
Topic: detectionState Proximity sensor C++
Replies: 1
Views: 1789

detectionState Proximity sensor C++

Hello When I use a proximity sensor with Matlab, I use this API function: [number errorCode,boolean detectionState,array detectedPoint,number detectedObjectHandle,array detectedSurfaceNormalVector]=simxReadProximitySensor(number clientID,number sensorHandle,number operationMode) So the "detectionSta...
by jegovila
15 Jul 2013, 22:06
Forum: General questions
Topic: Hokuyo laser and Kuka's YouBot (C++)
Replies: 1
Views: 3561

Hokuyo laser and Kuka's YouBot (C++)

Hello I control the YouBot's omnidirectional wheels with a client in C++, but now I want to add a laser to my application. I am using the Hokuyo Laser as a child of the Kuka's YouBot but when I call the function: result=simLaunchExecutable('Client',portNb.." "..wheelJoints[1].." "..wheelJoints[2].."...
by jegovila
15 Jul 2013, 16:54
Forum: General questions
Topic: Client is running over and over.
Replies: 4
Views: 2246

Re: Client is running over and over.

Thanks!!

That was the problem.
by jegovila
11 Jul 2013, 18:35
Forum: General questions
Topic: Client is running over and over.
Replies: 4
Views: 2246

Client is running over and over.

Hello I am using the example of the Bubblerob Server/Client with C++ and it works perfect. But When I want to replace the bubblerob with the Kuka's YouBot It works great but just for a little time, after few seconds the simulator becomes too slow. I tried this.. When I call the function "simLaunchEx...
by jegovila
26 Jun 2013, 02:47
Forum: General questions
Topic: Missing commThreadCycleInMs in simxStart
Replies: 1
Views: 1355

Missing commThreadCycleInMs in simxStart

Hello I am using V-REP as a server for a Matlab client but the responsiveness is very slow. The remote api functions "simxStart" has the following Matlab parameter: "commThreadCycleInMs: indicates how often data packets are sent back and forth. Reducing this number improves responsiveness, and a def...