Search found 17 matches

by lpitonakova
13 Feb 2018, 12:11
Forum: Bug reports
Topic: Using -s and -h parameters crashes v-rep
Replies: 3
Views: 260

Re: Using -s and -h parameters crashes v-rep

Just tried to removing the -s parameter and instead writing a plugin that runs simStartSimulation() after the scene has loaded, with the same crash effect.
by lpitonakova
13 Feb 2018, 11:47
Forum: Bug reports
Topic: Using -s and -h parameters crashes v-rep
Replies: 3
Views: 260

Using -s and -h parameters crashes v-rep

Hi, I am trying to run a simulation in headless mode and start it automatically. This previously worked fine in V-REP 3.4., however, in 3.5., when I do e.g. ./vrep -h -s ~.../scenes/e-puckDemo.ttt V-Rep crashes immediately with ... Initializing the Bullet physics engine in plugin 'DynamicsBullet_2_7...
by lpitonakova
13 Feb 2018, 10:46
Forum: Bug reports
Topic: Could not find or correctly load the video compression library.
Replies: 6
Views: 559

Re: Could not find or correctly load the video compression library.

Hi, is there an estimate of when this can be fixed a new version of V-REP for Mac released?
by lpitonakova
05 Feb 2018, 18:54
Forum: General questions
Topic: How do I install ROS interface on Indigo (Ubuntu 14.04)
Replies: 3
Views: 379

Re: How do I install ROS interface on Indigo (Ubuntu 14.04)

I have realised that there is another post related to this, the solution worked for me:
viewtopic.php?f=9&t=5567
by lpitonakova
05 Feb 2018, 17:47
Forum: General questions
Topic: How do I install ROS interface on Indigo (Ubuntu 14.04)
Replies: 3
Views: 379

Re: How do I install ROS interface on Indigo (Ubuntu 14.04)

I have copied these files (I am on Ubuntu 16.04) but when I try to run v-rep now it crashes with symbol lookup error: /home/lenka/Projects/nuclear/simulator/libv_repExtRosInterface.so: undefined symbol: _ZN3ros4initERiPPcRKSsj I have started roscore prior to running vrep. I have also tried compiling...
by lpitonakova
05 Feb 2018, 15:26
Forum: General questions
Topic: Streaming video camera
Replies: 14
Views: 1327

Re: Streaming video camera

Hi again, after some digging, I don't think that the buffer is the problem. I went back to start and looked at your example scene headlessModeDebug. Since in that scene, the rendering is over pretty quickly, as the robot falls off, I loaded a different scene through the script. That all works fine u...
by lpitonakova
05 Feb 2018, 13:03
Forum: General questions
Topic: Streaming video camera
Replies: 14
Views: 1327

Re: Streaming video camera

Also, I have another question about releasing. The description of simxGetVisionSensorImage (http://www.coppeliarobotics.com/helpFiles/en/remoteApiFunctions.htm#simxGetVisionSensorImage)says that the data is automatically released. When I try this: simUChar* image = new simUChar{}; if (simxGetConnect...
by lpitonakova
05 Feb 2018, 12:07
Forum: General questions
Topic: Streaming video camera
Replies: 14
Views: 1327

Re: Streaming video camera

Ok - I made the char* array (I assume that's what you mean by buffer) a class variable. So, are you saying that it's better to just create and delete a new buffer in every loop? Wouldn't that be slower?
by lpitonakova
30 Jan 2018, 20:08
Forum: General questions
Topic: Streaming video camera
Replies: 14
Views: 1327

Re: Streaming video camera

Thanks, but I really need to use the RemoteAPI, because eventually, I will want to write a renderer in Unity or similar. Or would BlueZero handle that too? I.e. using the vision sensor data in an arbitrary program? My problem does persist when images are smaller and yes, it gets stuck quicker when t...
by lpitonakova
30 Jan 2018, 12:15
Forum: General questions
Topic: Streaming video camera
Replies: 14
Views: 1327

Re: Streaming video camera

Just wanted to add here a function that I initially use to start streaming from a given vision sensor. The CameraControl class keeps a list of visual sensors (obtained at the beginning of the program from the RemoteAPI) - this list basically has the sensor names and resolution. Then there is a drop-...