Search found 9 matches

by WZJ
13 Mar 2018, 07:11
Forum: General questions
Topic: Plugin RosInterface not loading
Replies: 8
Views: 1702

Re: Plugin RosInterface not loading

how can you deal with this problem ? now i have the same problem, i have the file libv_repExtRosInterface.so but i can't Plugin rosinterface when i input ./vrep/sh Did you copy it to V-REP directory? (the same directory as where vrep.sh is) well, i found the problem. It was because that i can't bui...
by WZJ
11 Mar 2018, 03:50
Forum: General questions
Topic: Plugin RosInterface not loading
Replies: 8
Views: 1702

Re: Plugin RosInterface not loading

I'm having the same issue but on a fresh install of V3.5. After changing the directory name to vrep_ros_interface, it builds fine with catkin build in ~/catkin_ws/src (along with the other 3 from the tutorial), but it is not a .so directory...? I'm then copying the 4 directories to the V-REP root f...
by WZJ
10 Mar 2018, 17:39
Forum: General questions
Topic: how can i open an old ros-scene
Replies: 2
Views: 401

Re: how can i open an old ros-scene

Hi WZJ, the ROS plugin is deprecated. With the new RosInterface plugin it should be easier to set up publishers for any kind of data with a simple script. Have a look at the ROS tutorial in the manual. The new RosInterface plugin do be easier and read comfortable , but maybe i should spend a little...
by WZJ
10 Mar 2018, 11:15
Forum: General questions
Topic: how can i open an old ros-scene
Replies: 2
Views: 401

how can i open an old ros-scene

when i upgrade my v-rep version to 3.5.0, i find that the scene that i build in the old version failed to work well. it just says that "ROS plugin was not found." Simulation will not run properly. I think it is possible that the new version do not include (libv_repExtRos.so or libv_repExtRos.dylib) ...
by WZJ
13 Feb 2018, 04:29
Forum: Bug reports
Topic: a bug of getting the mouse position
Replies: 2
Views: 506

Re: a bug of getting the mouse position

coppelia wrote:
13 Feb 2018, 03:19
Hello,

which V-REP version and platform are you using? It seems to be working fine in V-REP V3.5.0

Cheers
well, wonderful. my version is V3.4.0 and when i download V3.5.0, it can Perfectly solute this problem.

cheers~!
by WZJ
12 Feb 2018, 12:07
Forum: General questions
Topic: path planning
Replies: 3
Views: 813

Re: path planning

well , when i use OMPL to plan the path. the same problem happened. dummy is the parent. and my robot cannot follow the dummy to run.
by WZJ
12 Feb 2018, 10:34
Forum: Bug reports
Topic: a bug of getting the mouse position
Replies: 2
Views: 506

a bug of getting the mouse position

i use the code to get my mouse x and y position x_pos = simGetInt32Parameter(sim_intparam_mouse_x) y_pos = simGetInt32Parameter(sim_intparam_mouse_y) print(x_pos, y_pos,) but the data y_pos is the same as x_pos. Even if i change my code like this. y_pos = simGetInt32Parameter(sim_intparam_mouse_y) p...
by WZJ
12 Feb 2018, 08:47
Forum: General questions
Topic: path planning
Replies: 3
Views: 813

Re: path planning

and this is my module.
https://github.com/wzjscut/my_Vrep
by WZJ
12 Feb 2018, 08:40
Forum: General questions
Topic: path planning
Replies: 3
Views: 813

path planning

Hello, I have a question when i use the dummy for parent. Just like the example of practicalPathPlanningDemo.ttt , I put my robot under the start dummy. But when my robot is moving, the dummy do not follow. I have tried many times and check all the possible possibility problem, but it doesn't work. ...