Search found 31 matches

by Uli_v
27 Jun 2019, 16:57
Forum: Bug reports
Topic: Remote API (legacy) client sends command to wrong remote API host
Replies: 2
Views: 307

Re: Remote API (legacy) client sends command to wrong remote API host

I though that these just specify the configuration of the servers (if started), but they actually start the servers too? I will comment them out and try again. I got this in the remoteApiConnections.txt (for V-REP 3.6.1 rev3). portIndex1_port = 19997 portIndex1_debug = false portIndex1_syncSimTrigge...
by Uli_v
26 Jun 2019, 22:41
Forum: General questions
Topic: How to use pyrep with V-REP 3.6.2 to replace/call (legacy) remote api calls to reduce communication delay
Replies: 1
Views: 221

How to use pyrep with V-REP 3.6.2 to replace/call (legacy) remote api calls to reduce communication delay

I would like to use pyrep (https://github.com/stepjam/PyRep) to reduce the communication delay between my python script (client) and V-REP. How easy is it to reuse my custom remote API function calls? Can I simply use pyrep to start V-REP within my script in a thread and call remote API function dir...
by Uli_v
26 Jun 2019, 17:42
Forum: Bug reports
Topic: sim.importShape() sometimes crashes when using more than 1 remote API (legacy) server
Replies: 1
Views: 175

Re: sim.importShape() sometimes crashes when using more than 1 remote API (legacy) server

I also tried with V-REP 3.6.1 rev3. Here the importShape call also eventually fails (after around the same number of calls), but it returns with -1 for the shapeHandle. It prints this to the terminal: importShape call Assimp: importing '/home/uli/vrep_ur5/simulation/objects/plane_2cm_dia_2x2xp1.stl'...
by Uli_v
26 Jun 2019, 16:36
Forum: Bug reports
Topic: sim.importShape() sometimes crashes when using more than 1 remote API (legacy) server
Replies: 1
Views: 175

sim.importShape() sometimes crashes when using more than 1 remote API (legacy) server

I am using one remote API client and 2 remote API servers, where I sometimes call sim.importShape() via custom remote API call. I don't call them at the same time for different servers. After a few times (order of 5-15), the call fails and I get this error message below in the console. This issue mi...
by Uli_v
26 Jun 2019, 16:17
Forum: Bug reports
Topic: V-REP crash (running several instances of V-REP with several remote API clients)
Replies: 13
Views: 1835

Re: V-REP crash (running several instances of V-REP with several remote API clients)

I git cloned: https://github.com/CoppeliaRobotics/v_repExtRemoteApi

I then I tried:

Code: Select all

cmake -DCMAKE_BUILD_TYPE=Debug
But there is no CMakeLists.txt.

What are all the steps necessary to build/cmake the RemoteApi plugin? Thanks.
by Uli_v
25 Jun 2019, 17:25
Forum: Bug reports
Topic: Remote API (legacy) client sends command to wrong remote API host
Replies: 2
Views: 307

Remote API (legacy) client sends command to wrong remote API host

In my small working example to reproduce the bug I have two remote API clients that communicate to 4 remote API servers. The clients connect to the simulation, restart (stop/start) the simulation, print something to two terminals and console of the simulator (via remote API calls). If I do that with...
by Uli_v
25 Jun 2019, 16:56
Forum: Bug reports
Topic: V-REP crash (running several instances of V-REP with several remote API clients)
Replies: 13
Views: 1835

Re: V-REP crash (running several instances of V-REP with several remote API clients)

Hi Uli_v, I'm trying to replicate the crash to no avail. Can you try to compile the plugin in debug mode and have it crashing within the debugger to see exactly at which line is crashing? How do I compile the plugin in debug mode? I can run my code in debug mode, but it might take some time until i...
by Uli_v
05 Apr 2019, 21:38
Forum: Bug reports
Topic: V-REP crash (running several instances of V-REP with several remote API clients)
Replies: 13
Views: 1835

V-REP crash (running several instances of V-REP with several remote API clients)

Any idea where I would need to look at to fix the problem? Is there a threading issue? Is it the remoteAPI? It seems to happen only if I run several instances of V-REP with several instances of remote API clients (python). I am running V3.5.0. *** buffer overflow detected ***: /home/uli/Software/V-R...
by Uli_v
21 Mar 2019, 16:35
Forum: Bug reports
Topic: Depth Sensor Seeing Through Walls
Replies: 4
Views: 1659

Re: Depth Sensor Seeing Through Walls

I just found that I have the same issue with looking through objects. I agree with davicarnauba84. In the real world, if an object is too close to the depth sensor, then the depth readings become 0 (at least for the Intel Realsense SR300). The problem is that the shapes are not solid (they are meshe...