Mouse and appearance problems

Report crashes, strange behaviour, or apparent bugs
Elez
Posts: 32
Joined: 11 Oct 2014, 17:29

Mouse and appearance problems

Post by Elez » 11 Oct 2014, 19:10

Hello,

I have just installed V REP PRO EDU 3.1.3 rev2b on my windows 7 laptop and I'm experiencing problems with the mouse position detection and with the appearance of the program. My laptop has a 15.6" HD LCD screen.

The mouse doesn't click were I actually click and it's imposible to work like this. As for the appearance there are two black strips that I think they should not be there. There's one just above "Model browser", "Scene hierarchy" and "Selected objects" and the other one is at the left of "Model browser". You can see what I'm talking about in this screenshot Image.

Finally there's a bug that I don't know how to describe. It's like a white and grey little strip constantly appearing and disappearing just below "Model browser" and "Scene hierarchy". I can't catch it on a screenshot so I hope I've explained it well.

I expect your answer,
Thank you.

coppelia
Site Admin
Posts: 7150
Joined: 14 Dec 2012, 00:25

Re: Mouse and appearance problems

Post by coppelia » 12 Oct 2014, 00:26

Hello,

as far as I can tell, this is linked to an incompatibility issue with Qt or OpenGl. You can try to adjust the values of variables renderingSurfaceVShift and renderingSurfaceVResize in file system/usrset.txt.

Let us know if that makes a difference.

Cheers

Elez
Posts: 32
Joined: 11 Oct 2014, 17:29

Re: Mouse and appearance problems

Post by Elez » 12 Oct 2014, 18:19

Hello,

I've tried changing those values but there's no improvement. I've tried a lot of different numbers, even negatives. Any idea of values to try? I've also tried changing my screen resolution but it doesn't work either.

What can I do?

Thanks.

coppelia
Site Admin
Posts: 7150
Joined: 14 Dec 2012, 00:25

Re: Mouse and appearance problems

Post by coppelia » 12 Oct 2014, 18:35

Can you try to change the settings of your graphic card?

Elez
Posts: 32
Joined: 11 Oct 2014, 17:29

Re: Mouse and appearance problems

Post by Elez » 12 Oct 2014, 19:11

I'm not sure, what would be necessary to change?

coppelia
Site Admin
Posts: 7150
Joined: 14 Dec 2012, 00:25

Re: Mouse and appearance problems

Post by coppelia » 13 Oct 2014, 16:02

Can you try following:
  • update your GPU driver
  • try to disable hardware acceleration for your GPU
what is your GPU?

Cheers

Elez
Posts: 32
Joined: 11 Oct 2014, 17:29

Re: Mouse and appearance problems

Post by Elez » 13 Oct 2014, 16:42

My GPU is an ATI Mobility Radeon HD 4570. I've updated drivers and I think I've hardware aceleration disabled as you can see:
Image

Elez
Posts: 32
Joined: 11 Oct 2014, 17:29

Re: Mouse and appearance problems

Post by Elez » 13 Oct 2014, 17:28

I've tried installing an older version (3.1.2) and I had the same problems. But, I've just installed the 3.0.5 one and it seems to work fine:
Image

Which are the differences between 3.1.3 and 3.0.5?

coppelia
Site Admin
Posts: 7150
Joined: 14 Dec 2012, 00:25

Re: Mouse and appearance problems

Post by coppelia » 13 Oct 2014, 23:06

I am at a loss here, I can't explain that. In both versions Qt is in charge of setting up the drawing area, using a QGLWidget. But both versions use the same Qt version.

Can you try to remove the toolbars (or undock them) to see if that makes a difference? Also, can you try to change the size of the status bar to see if that affects anything?

Cheers

Elez
Posts: 32
Joined: 11 Oct 2014, 17:29

Re: Mouse and appearance problems

Post by Elez » 14 Oct 2014, 16:29

Changing the size of the status bar nothing change. On the other hand I don't know how to remove the toolbars.

Post Reply