Vrep crashing when using a remote X sesion

Report crashes, strange behaviour, or apparent bugs
Post Reply
fai
Posts: 3
Joined: 23 Sep 2015, 21:04

Vrep crashing when using a remote X sesion

Post by fai » 07 Nov 2016, 17:43

Hi Coppelia Team,

We are running some experiments in a remote cluster of computers. Due to the fact that the same experiment gives different results if it is run in a different computer, we want to run a simulation in the remote computer without running the headless mode. We are using Xming and a ssh connection with X11 forwarding. We are able to see the first splash screen but later the program crashes. This is the error that we found:

Code: Select all

afaina@fe1:~/V-REP_PRO_EDU_V3_3_2_64_Linux$ ./vrep.sh
failed to get the current screen resources
Using the default Lua library.
Loaded the video compression library.
QXcbConnection: XCB error: 170 (Unknown), sequence: 162, resource id: 90, major code: 146 (Unknown), minor code: 20
Add-on script 'vrepAddOnScript-addOnScriptDemo.lua' was loaded.
./vrep.sh: line 17: 14635 Segmentation fault      "$dirname/$appname" "$@"

We have also tried different versions and all of them crash. From version 3.2.1 and below, the error is different:

Code: Select all

afaina@fe1:~/oldVreps/V-REP_PRO_EDU_V3_2_1_64_Linux$ ./vrep.sh
This application failed to start because it could not find or load the Qt platform plugin "xcb".
Reinstalling the application may fix this problem.
./vrep.sh: line 17: 14955 Aborted                 "$dirname/$appname" "$@"


Any ideas?

coppelia
Site Admin
Posts: 6183
Joined: 14 Dec 2012, 00:25

Re: Vrep crashing when using a remote X sesion

Post by coppelia » 07 Nov 2016, 18:47

Hello,

did you have a look at this similar problem?

Cheers

fai
Posts: 3
Joined: 23 Sep 2015, 21:04

Re: Vrep crashing when using a remote X sesion

Post by fai » 07 Nov 2016, 19:35

Hi,

my problem is just the opposite. I can run vrep in headless mode but I cannot run it with the GUI.
I have also tried to run it with the xvfb-run command.

Code: Select all

afaina@fe1:~/V-REP_PRO_EDU_V3_3_2_64_Linux$ xvfb-run --auto-servernum --server-num=1 ./vrep.sh
Using the default Lua library.
Loaded the video compression library.
Unsupported screen format: depth: 8, red_mask: 0, blue_mask: 0
Unsupported screen format: depth: 8, red_mask: 0, blue_mask: 0
Xlib:  extension "GLX" missing on display ":1".
Xlib:  extension "GLX" missing on display ":1".
Xlib:  extension "GLX" missing on display ":1".
Xlib:  extension "GLX" missing on display ":1".
Could not initialize OpenGL for RasterGLSurface, reverting to RasterSurface.
Unsupported screen format: depth: 8, red_mask: 0, blue_mask: 0
QWidget::paintEngine: Should no longer be called
QPainter::begin: Paint device returned engine == 0, type: 1
QPainter::setPen: Painter not active
Add-on script 'vrepAddOnScript-addOnScriptDemo.lua' was loaded.
Xlib:  extension "GLX" missing on display ":1".
Xlib:  extension "GLX" missing on display ":1".
Xlib:  extension "GLX" missing on display ":1".
Xlib:  extension "GLX" missing on display ":1".
Xlib:  extension "GLX" missing on display ":1".
Xlib:  extension "GLX" missing on display ":1".
Xlib:  extension "GLX" missing on display ":1".
Xlib:  extension "GLX" missing on display ":1".
Could not initialize OpenGL
./vrep.sh: line 17: 19612 Aborted                 "$dirname/$appname" "$@"
and

Code: Select all

afaina@fe1:~/V-REP_PRO_EDU_V3_3_2_64_Linux$ xvfb-run --auto-servernum --server-num=1 -s "-screen 0 640x480x24" ./vrep.sh
Using the default Lua library.
Loaded the video compression library.
Xlib:  extension "GLX" missing on display ":1".
Xlib:  extension "GLX" missing on display ":1".
Xlib:  extension "GLX" missing on display ":1".
Xlib:  extension "GLX" missing on display ":1".
Could not initialize OpenGL for RasterGLSurface, reverting to RasterSurface.
Add-on script 'vrepAddOnScript-addOnScriptDemo.lua' was loaded.
Xlib:  extension "GLX" missing on display ":1".
Xlib:  extension "GLX" missing on display ":1".
Xlib:  extension "GLX" missing on display ":1".
Xlib:  extension "GLX" missing on display ":1".
Xlib:  extension "GLX" missing on display ":1".
Xlib:  extension "GLX" missing on display ":1".
Xlib:  extension "GLX" missing on display ":1".
Xlib:  extension "GLX" missing on display ":1".
Could not initialize OpenGL
./vrep.sh: line 17: 19808 Aborted                 "$dirname/$appname" "$@"

coppelia
Site Admin
Posts: 6183
Joined: 14 Dec 2012, 00:25

Re: Vrep crashing when using a remote X sesion

Post by coppelia » 09 Nov 2016, 14:34

Sorry, I think I cannot help you further here...

Why is the simulation different depending on the computer? What kind of simulation are you doing? What physics engine are you using?

Cheers

Post Reply