POV-Ray plugin crashes

Report crashes, strange behaviour, or apparent bugs
CodeFinder
Posts: 3
Joined: 05 Mar 2017, 01:06

POV-Ray plugin crashes

Postby CodeFinder » 05 Mar 2017, 18:43

Hi,

I've tried to use the "rendererDemo.ttt" ("File" -> "Open scene...") with V-REP PRO EDU 3.3.2 (rev. 3) 64 bit (no modifications) on Xubuntu 16.04 LTS 64 bit but V-REP crashes immediately with a segfault when clicking on "POY-Ray 320 x 240" (not even able to start recording or simulation):

Code: Select all

.../V-REP_PRO_EDU_V3_3_2_64_Linux$ ./vrep.sh
Using the default Lua library.
Loaded the video compression library.
Add-on script 'vrepAddOnScript-addOnScriptDemo.lua' was loaded.
Simulator launched.
Plugin 'MeshCalc': loading...
Plugin 'MeshCalc': load succeeded.
Plugin 'BubbleRob': loading...
Plugin 'BubbleRob': load succeeded.
Plugin 'Collada': loading...
Plugin 'Collada': load succeeded.
Plugin 'ConvexDecompose': loading...
Plugin 'ConvexDecompose': load succeeded.
Plugin 'CustomUI': loading...
Plugin 'CustomUI': load succeeded.
Plugin 'DynamicsBullet-2-78': loading...
Plugin 'DynamicsBullet-2-78': load succeeded.
Plugin 'DynamicsBullet-2-83': loading...
Plugin 'DynamicsBullet-2-83': load succeeded.
Plugin 'DynamicsNewton': loading...
Plugin 'DynamicsNewton': load succeeded.
Plugin 'DynamicsOde': loading...
Plugin 'DynamicsOde': load succeeded.
Plugin 'DynamicsVortex': loading...
Plugin 'DynamicsVortex': load succeeded.
Plugin 'ExternalRenderer': loading...
Plugin 'ExternalRenderer': load succeeded.
Plugin 'K3': loading...
Plugin 'K3': load succeeded.
Plugin 'LuaRemoteApiClient': loading...
Plugin 'LuaRemoteApiClient': load succeeded.
Plugin 'Mtb': loading...
Plugin 'Mtb': load succeeded.
Plugin 'OMPL': loading...
Plugin 'OMPL': load succeeded.
Plugin 'OpenMesh': loading...
Plugin 'OpenMesh': load succeeded.
Plugin 'PovRay': loading...
Plugin 'PovRay': load succeeded.
Plugin 'Qhull': loading...
Plugin 'Qhull': load succeeded.
Plugin 'RRS1': loading...
Plugin 'RRS1': load succeeded.
Plugin 'ReflexxesTypeIV': loading...
Plugin 'ReflexxesTypeIV': load succeeded.
Plugin 'RemoteApi': loading...
Starting a remote API server on port 19997
Plugin 'RemoteApi': load succeeded.
Plugin 'SDF': loading...
Plugin 'SDF': load succeeded.
Plugin 'SimpleFilter': loading...
Plugin 'SimpleFilter': load succeeded.
Plugin 'Urdf': loading...
Plugin 'Urdf': load succeeded.
Plugin 'Vision': loading...
Plugin 'Vision': load succeeded.
Using the 'MeshCalc' plugin.
0x2a1e3b0 void QWindowPrivate::setTopLevelScreen(QScreen*, bool) ( QScreen(0x26d7d80) ): Attempt to set a screen on a child window.
0x3031490 void QWindowPrivate::setTopLevelScreen(QScreen*, bool) ( QScreen(0x26d50b0) ): Attempt to set a screen on a child window.
0x30310d0 void QWindowPrivate::setTopLevelScreen(QScreen*, bool) ( QScreen(0x26d50b0) ): Attempt to set a screen on a child window.
0x302e000 void QWindowPrivate::setTopLevelScreen(QScreen*, bool) ( QScreen(0x26d50b0) ): Attempt to set a screen on a child window.
0x2a1e3b0 void QWindowPrivate::setTopLevelScreen(QScreen*, bool) ( QScreen(0x26d50b0) ): Attempt to set a screen on a child window.
0x2f94360 void QWindowPrivate::setTopLevelScreen(QScreen*, bool) ( QScreen(0x26d50b0) ): Attempt to set a screen on a child window.
0x2f94870 void QWindowPrivate::setTopLevelScreen(QScreen*, bool) ( QScreen(0x26d50b0) ): Attempt to set a screen on a child window.
0x302e990 void QWindowPrivate::setTopLevelScreen(QScreen*, bool) ( QScreen(0x26d50b0) ): Attempt to set a screen on a child window.
QMutex: destroying locked mutex


What's the problem here? (I can click on all other buttons w/o crashes.) Please note that the previous output ("Attempt to set a screen on a child window.") does not seem to have something in common with the issue.

Kind regards and thanks in advance!

coppelia
Site Admin
Posts: 6058
Joined: 14 Dec 2012, 00:25

Re: POV-Ray plugin crashes

Postby coppelia » 05 Mar 2017, 22:57

Hello,

so a different resolution with the POV-Ray plugin works without crash? Is it just with that resolution?

Cheers

CodeFinder
Posts: 3
Joined: 05 Mar 2017, 01:06

Re: POV-Ray plugin crashes

Postby CodeFinder » 06 Mar 2017, 00:11

No, sorry. It crashes on all resolutions. Never got it working yet. (The "I can click on all other buttons w/o crashes" was just related to the other rendering options, not to POV-Ray. Sorry for the confusion.)

coppelia
Site Admin
Posts: 6058
Joined: 14 Dec 2012, 00:25

Re: POV-Ray plugin crashes

Postby coppelia » 06 Mar 2017, 07:54

hmmm, first time I hear that. What version of Ubuntu are you running? 32 or 64bit?
Can you try to recompile the plugin? In that case, you should make sure to use the same Qt version that was used to compile V-REP, otherwise you will run into other problems.

Cheers

CodeFinder
Posts: 3
Joined: 05 Mar 2017, 01:06

Re: POV-Ray plugin crashes

Postby CodeFinder » 06 Mar 2017, 13:14

As written in my first post, I am using the 64 bit version of (X)Ubuntu. Will have a look at compiling V-REP + plugins when I'll have the time for it (guess it's easier to compile both with my Qt 5.7.0 installation than trying to figure out how to forcefully use the shipped version Qt v5.5.0).

Thanks anyway.


Return to “Bug reports”

Who is online

Users browsing this forum: No registered users and 2 guests