Trouble running V-REP headless

Report crashes, strange behaviour, or apparent bugs
Posts: 8
Joined: 18 Aug 2016, 04:03

Trouble running V-REP headless

Postby IanCol » 23 Mar 2017, 23:42

Hi There,

I've installed Ubuntu 16.04 and the latest version of V-REP on a desktop computer that we plan to use as a server. I am trying to get V-REP to run headless so that we can ssh in and run headless simulations. I can get it to run headless if I am logged in locally, but nothing will work over ssh.

I tried:
~/opt/vrep/V-REP_PRO_EDU_V3_3_2_64_Linux/ -h -s5000 -q

And got the error:

Code: Select all

QXcbConnection: Could not connect to display
Aborted (core dumped)

I also tried:
xvfb-run --auto-servernum --server-num=1 ~/opt/vrep/V-REP_PRO_EDU_V3_3_2_64_Linux/ -h -s5000 -q

And got the error:

Code: Select all

/home/ian/opt/vrep/V-REP_PRO_EDU_V3_3_2_64_Linux/ line 33: 24574 Floating point exception(core dumped) "$dirname/$appname" "${PARAMETERS[@]}"

1. What am I doing wrong?
2. Is V-REP able to run truly headless?


Site Admin
Posts: 5743
Joined: 14 Dec 2012, 00:25

Re: Trouble running V-REP headless

Postby coppelia » 25 Mar 2017, 12:05

Hello Ian,

When you start V-REP in headless mode, you basically run the exact same binaries as the V-REP with GUI. It is not a true headless version of V-REP. I see currently two possibilities:

  • You can try to run with different graphic settings and see if this makes a difference. Have a look at file system/usrset.txt. In there, try out different values for offscreenContextType, fboType, forceFboViaExt and vboOperation.
  • You can recompile V-REP in true headless mode by compiling V-REP with the makefile_noGui_noGl makefile. In that case however, vision sensors will only work if they rely on a plugin for image generation (e.g. v_repExtPovRay).

Have also a look at this topic.


Return to “Bug reports”

Who is online

Users browsing this forum: No registered users and 5 guests