Segfault on start-up in Ubuntu 18.04

Report crashes, strange behaviour, or apparent bugs
Post Reply
Posts: 1
Joined: 22 Apr 2018, 12:35

Segfault on start-up in Ubuntu 18.04

Post by petrc » 24 Apr 2018, 14:16

I moved from Ubuntu 16.04 to Ubuntu 18.04 and try to run V-REP 3.5. It crashes with the following output:

Code: Select all

Using the default Lua library.
Loaded the video compression library.
Add-on script 'vrepAddOnScript-addOnScriptDemo.lua' was loaded.
Error: signal 11:[0x7f5e989400c8]
Using backtrace in gdb I obtained the following result:

Code: Select all

#0  0x0000000000000000 in  ()
#1  0x00007ffff11cc19f in QOpenGLContext::makeCurrent(QSurface*) () at ./
#2  0x00007ffff2060cf2 in QGLContext::makeCurrent() () at ./
#3  0x00007ffff30df4df in CMainWindow::CMainWindow() () at ./
#4  0x00007ffff2db5ea4 in App::createMainWindow() () at ./
#5  0x00007ffff2c27725 in simRunSimulator_internal(char const*, int, void (*)(), void (*)(), void (*)()) () at ./
#6  0x00000000004020f2 in main ()
So, it seems that the program is wrongly setting the OpenGL canvas.

I tried to change the provided libQt5 and liblua for the system ones, but with no success.
I searched this forum and found: Weird segfault in liblua (v.3.5.0) which is somehow similar to problems that I am experiencing and might be related.

Note, in headless mode, the program starts correctly.
Finally, I tried to revert back to the V-REP 3.4 and it works.

Site Admin
Posts: 6766
Joined: 14 Dec 2012, 00:25

Re: Segfault on start-up in Ubuntu 18.04

Post by coppelia » 26 Apr 2018, 08:01


Ubuntu 18.04 was not tested yet, since the official release date of Ubuntu 18.04 is today.
It will probably only be supported next time we make a V-REP release. Probably by compiling V-REP with a newer version of Qt, you might get rid of the crash.


Posts: 16
Joined: 05 May 2018, 13:25

Re: Segfault on start-up in Ubuntu 18.04

Post by ariyayi » 24 May 2018, 22:01

I have same error for running v-rep 3.5.0 on ubuntu 18.04. Is it possible to fix it or must wait for newer v-rep version ?

Posts: 2
Joined: 26 May 2017, 19:14

Re: Segfault on start-up in Ubuntu 18.04

Post by fabro » 05 Sep 2018, 19:24

Dear all,

I've had the same problem with Ubuntu 18.04. Today I've tried to install a few packages on a "new" installation, and somehow managed to get V-REP working!

The packages I installed were:

- sudo apt-get install libboost-all-dev
(surely people have installed it already, so this should not be the problem!)

- sudo apt-get install lua5.1
- sudo apt-get install liblua5.1-0
- sudo apt-get install liblua5.1-0-dev
(maybe this could be a problem, the "default" lua in Ubuntu 18.04 appears to be 5.2 or 5.3......)

- sudo apt install qtcreator
- sudo apt-get install qt5-default
(maybe this could help....but maybe not....)

QScintilla 2.10.7 from: ... a/download
After download and expand, the commands necessary were:
- qmake
- make
- sudo make install
(so I've had to install first qmake, part of qtcreator and qt5: see above!)

After that, vrep started to work!!!! Hope you enjoy!

Best regards, Joao Fabro

Posts: 225
Joined: 09 Sep 2013, 19:28

Re: Segfault on start-up in Ubuntu 18.04

Post by fferri » 05 Sep 2018, 22:40

You need to install also libqt5serialport5-dev which is not pulled in by qt5-default.

See also this issue for fixing additional build errors (namely: error stdlib.h: no such file or directory) caused by gcc 6 + qmake

Post Reply