Segfault on start-up in Ubuntu 18.04

Report crashes, strange behaviour, or apparent bugs
Post Reply
petrc
Posts: 1
Joined: 22 Apr 2018, 12:35

Segfault on start-up in Ubuntu 18.04

Post by petrc » 24 Apr 2018, 14:16

Hello,
I moved from Ubuntu 16.04 to Ubuntu 18.04 and try to run V-REP 3.5. It crashes with the following output:

Code: Select all

Using the default Lua library.
Loaded the video compression library.
Add-on script 'vrepAddOnScript-addOnScriptDemo.lua' was loaded.
Error: signal 11:
libv_rep.so(_Z11_segHandleri+0x28)[0x7f5e989400c8]
/lib/x86_64-linux-gnu/libc.so.6(+0x3ef20)[0x7f5e9ca6af20]
Using backtrace in gdb I obtained the following result:

Code: Select all

#0  0x0000000000000000 in  ()
#1  0x00007ffff11cc19f in QOpenGLContext::makeCurrent(QSurface*) () at ./libQt5Gui.so.5
#2  0x00007ffff2060cf2 in QGLContext::makeCurrent() () at ./libQt5OpenGL.so.5
#3  0x00007ffff30df4df in CMainWindow::CMainWindow() () at ./libv_rep.so
#4  0x00007ffff2db5ea4 in App::createMainWindow() () at ./libv_rep.so
#5  0x00007ffff2c27725 in simRunSimulator_internal(char const*, int, void (*)(), void (*)(), void (*)()) () at ./libv_rep.so
#6  0x00000000004020f2 in main ()
So, it seems that the program is wrongly setting the OpenGL canvas.

I tried to change the provided libQt5 and liblua for the system ones, but with no success.
I searched this forum and found: Weird segfault in liblua (v.3.5.0) which is somehow similar to problems that I am experiencing and might be related.

Note, in headless mode, the program starts correctly.
Finally, I tried to revert back to the V-REP 3.4 and it works.

coppelia
Site Admin
Posts: 6740
Joined: 14 Dec 2012, 00:25

Re: Segfault on start-up in Ubuntu 18.04

Post by coppelia » 26 Apr 2018, 08:01

Hello,

Ubuntu 18.04 was not tested yet, since the official release date of Ubuntu 18.04 is today.
It will probably only be supported next time we make a V-REP release. Probably by compiling V-REP with a newer version of Qt, you might get rid of the crash.

Cheers

ariyayi
Posts: 16
Joined: 05 May 2018, 13:25

Re: Segfault on start-up in Ubuntu 18.04

Post by ariyayi » 24 May 2018, 22:01

I have same error for running v-rep 3.5.0 on ubuntu 18.04. Is it possible to fix it or must wait for newer v-rep version ?

Post Reply