Version 3.6.2 displays edges in white (for imported meshes)

Report crashes, strange behaviour, or apparent bugs
Post Reply
Adrian
Posts: 8
Joined: 22 Jun 2018, 23:03

Version 3.6.2 displays edges in white (for imported meshes)

Post by Adrian » 16 Oct 2019, 00:45

Hi,

I don't know if this is intended or not, but I noticed that somewhere between version 3.5.0 and version 3.6.2, the displayed edge color changed from black to white for shapes that were imported using the mesh import tool. For primitive shapes, the edge color still remains black.

When I load VREP models that were originally created with version 3.5.0 into version 3.6.2, they will still have black edges. But any new models that I create in version 3.6.2 have white edges now. In case this is intentional, is there maybe a way to define the edge color for a shape, so that I can make all shapes in the scene have consistent colors?

The documentation currently only mentions black as the edge color of shapes.

Below is a screen shot from VREP 3.6.2 Ubuntu 64bit. The most left cuboid is a primitive shape. The other cuboids were created by exporting the primitive shape to mesh files (.obj, .ply, .stl, and .dae) and then re-importing the mesh files again.
Image

For comparison, below is what you obtain with VREP 3.5.0 (.obj, .stl).
Image

Best,
Adrian

coppelia
Site Admin
Posts: 7396
Joined: 14 Dec 2012, 00:25

Re: Version 3.6.2 displays edges in white (for imported meshes)

Post by coppelia » 18 Oct 2019, 12:13

Hello Adrian,

can you open the user settings (the last toolbar button on the left hand side), and in adjust OpenGL settings disable VBO operation? My guess is that it is linked to a particular graphic card.

Cheers

Adrian
Posts: 8
Joined: 22 Jun 2018, 23:03

Re: Version 3.6.2 displays edges in white (for imported meshes)

Post by Adrian » 18 Oct 2019, 17:33

Thanks for this tip! Disabling VBO makes the edges look a little bit better. They are gray now. It is still clearly different though. I switched to a different machine with the same result (both Ubunutu 16.04).

My workaround for now is to load the mesh into VREP 3.5.0 and then save the object as a VREP model. I can then load the VREP model into a scene in version 3.6.2 and the edges will look fine and continue working in 3.6.2 for everything else.

Out of curiosity, I tried to do the opposite as well, and the white edges also show up in version 3.5.0 when I load a model that was saved with VREP 3.6.2.

Below is a link to a scene file that should show white and black edges at the same time. I first created a primitive cuboid in 3.5.0 (first row). Then, I exported the cuboid to OBJ and STL and imported it again (second row). Then, I saved the scene and opened it in VREP 3.6.2 and imported the same two meshes again (third row).

Cuboids.ttt

If you open the above Cuboids.ttt scene file with any VREP version, you might see some shapes with white edges and some shape with black edges, as shown in the screen shot below.
Image

Intermediate files that I created to obtain the above scene file:
cuboid-model-3.6.2.ttm
cuboid-model-3.5.0.ttm
cuboid.obj
cuboid.stl

Best,
Adrian

Maenre
Posts: 8
Joined: 29 Jul 2019, 11:10

Re: Version 3.6.2 displays edges in white (for imported meshes)

Post by Maenre » 19 Oct 2019, 17:02

What works for me is creating the primitive shape and applying its color properties to my mesh body (1st select mesh, then ctrl+select primitive shape).

https://drive.google.com/open?id=1AENHd ... jSq6TPVloK

https://drive.google.com/open?id=1r7mS- ... ntr3xHoDkt

Adrian
Posts: 8
Joined: 22 Jun 2018, 23:03

Re: Version 3.6.2 displays edges in white (for imported meshes)

Post by Adrian » 21 Oct 2019, 16:10

Thank you for sharing this workaround! It works for me too!

- Adrian

coppelia
Site Admin
Posts: 7396
Joined: 14 Dec 2012, 00:25

Re: Version 3.6.2 displays edges in white (for imported meshes)

Post by coppelia » 22 Oct 2019, 09:06

Sorry, I misread your post. Indeed, when importing, the edge color changes. This will be fixed in next release.

Thanks again

Post Reply