Failed to open the shared memory "/LocalVREP_REMOTE_API00001"

Typically: "How do I... ", "How can I... " questions
Post Reply
davicarnauba84
Posts: 9
Joined: 09 Jan 2018, 17:14

Failed to open the shared memory "/LocalVREP_REMOTE_API00001"

Post by davicarnauba84 » 16 Feb 2018, 01:50

Can't communicate with VREP using shared memory. The connection fails when using a negative port.

coppelia
Site Admin
Posts: 6683
Joined: 14 Dec 2012, 00:25

Re: Failed to open the shared memory "/LocalVREP_REMOTE_API00001"

Post by coppelia » 16 Feb 2018, 03:07

Hello,

which platform are you running on?

Cheers

davicarnauba84
Posts: 9
Joined: 09 Jan 2018, 17:14

Re: Failed to open the shared memory "/LocalVREP_REMOTE_API00001"

Post by davicarnauba84 » 13 Mar 2018, 18:52

Linux - Ubuntu 17.10
Trying to connect Java client through shared memory to V-REP

coppelia
Site Admin
Posts: 6683
Joined: 14 Dec 2012, 00:25

Re: Failed to open the shared memory "/LocalVREP_REMOTE_API00001"

Post by coppelia » 14 Mar 2018, 07:57

Please try following:
  • in programming/remoteApiBindings/Java/Java/simpleTest.java, replace 19999 with 19997 on line 23
  • Launch V-REP, and then run simpleTest.java.
Does above work? If yes, try following:
  • in programming/remoteApiBindings/Java/Java/simpleTest.java, replace 19997 with -3 on line 23
  • in V-REP-folder/remoteApiConnections.txt, replace 19997 with -3.
  • Launch V-REP, and then run simpleTest.java.
What about now?

Cheers

davicarnauba84
Posts: 9
Joined: 09 Jan 2018, 17:14

Re: Failed to open the shared memory "/LocalVREP_REMOTE_API00001"

Post by davicarnauba84 » 14 Mar 2018, 14:08

not working...

output:
Mouse position x: 897
Mouse position x: 897
Mouse position x: 897
Mouse position x: 897
Mouse position x: 897
Mouse position x: 897
Mouse position x: 897
Mouse position x: 897
davi@davi-X550CA:~/V-REP_PRO_EDU_V3_5_0_Linux/programming/remoteApiBindings/java/java$ javac simpleTest.java
davi@davi-X550CA:~/V-REP_PRO_EDU_V3_5_0_Linux/programming/remoteApiBindings/java/java$ java -Djava.library.path=../lib/Linux/64Bit/ simpleTest
Program started
Connect (0): Failed to open the shared memory "/LocalVREP_REMOTE_API00003"
Failed connecting to remote API server
Program ended

davicarnauba84
Posts: 9
Joined: 09 Jan 2018, 17:14

Re: Failed to open the shared memory "/LocalVREP_REMOTE_API00001"

Post by davicarnauba84 » 14 Mar 2018, 15:14

it worked! Thanks!!

Post Reply