How connect VREP & ROS Kinetic

Typically: "How do I... ", "How can I... " questions
Post Reply
Matheus
Posts: 8
Joined: 13 Apr 2019, 13:24

How connect VREP & ROS Kinetic

Post by Matheus » 15 May 2019, 19:36

Hello,

I´m trying to connect VREP with ROS. I´m following this instructions: https://github.com/LCAS/zoidbot/wiki/VR ... face-Setup

The point is that in the step number six, I have found some of the following issue:

CMake Warning at /opt/ros/kinetic/share/catkin/cmake/catkin_package.cmake:166 (message): catkin_package() DEPENDS on 'nav_msgs' but neither 'nav_msgs_INCLUDE_DIRS' nor 'nav_msgs_LIBRARIES' is defined. Call Stack (most recent call first): /opt/ros/kinetic/share/catkin/cmake/catkin_package.cmake:102 (_catkin_package) CMakeLists.txt:12 (catkin_package)

and I don´t know how to fix it.

Could anyone tell me how to do it?

Thank you,

fferri
Posts: 344
Joined: 09 Sep 2013, 19:28

Re: How connect VREP & ROS Kinetic

Post by fferri » 16 May 2019, 09:25

According to that guide, step 6, it tells you what to do:
Make sure you have those packages installed.
Did you install the nav-msgs package?

Matheus
Posts: 8
Joined: 13 Apr 2019, 13:24

How connect VREP & ROS Kinetic

Post by Matheus » 18 May 2019, 12:17

First of all, thanks for your reply.

Yes, I had installed all those packages and I could not solve it, so, forgetting that manual. I have tried with this other one: https://github.com/UnbDroid/Festo2018/w ... OS-e-V-Rep

Everything goes right until I execute "catkin build". The issue that I got in this case is the following one:

Code: Select all

[build] Found '1' packages in 0.0 seconds.                     
[build] Updating package table.                                
Starting  >>> catkin_tools_prebuild                            
Finished  <<< catkin_tools_prebuild                [ 2.6 seconds ]
Starting  >>> vrep_ros_interface                               
_______________________________________________________________
Errors     << vrep_ros_interface:cmake /tmp/quickstart_ws/logs/vrep_ros_interface/build.cmake.000.log
CMake Error at /tmp/quickstart_ws/src/vrep_ros_interface/cmake/CoppeliaRobotics-modules/FindVREP.cmake:69 (message):
  Found V-REP version 3.5.0.6 but 3.6.1.4 required.
Call Stack (most recent call first):
  CMakeLists.txt:38 (find_package)


cd /tmp/quickstart_ws/build/vrep_ros_interface; catkin build --get-env vrep_ros_interface | catkin env -si  /usr/bin/cmake /tmp/quickstart_ws/src/vrep_ros_interface --no-warn-unused-cli -DCATKIN_DEVEL_PREFIX=/tmp/quickstart_ws/devel/.private/vrep_ros_interface -DCMAKE_INSTALL_PREFIX=/tmp/quickstart_ws/install; cd -
...............................................................
Failed     << vrep_ros_interface:cmake             [ Exited with code 1 ]
Failed    <<< vrep_ros_interface                   [ 3.4 seconds ]
[build] Summary: 1 of 2 packages succeeded.                    
[build]   Ignored:   None.                                     
[build]   Warnings:  None.                                     
[build]   Abandoned: None.                                     
[build]   Failed:    1 packages failed.                        
[build] Runtime: 6.1 seconds total.                            
[build] Note: Workspace packages have changed, please re-source setup files to use them.
I focused on this "Found V-REP version 3.5.0.6 but 3.6.1.4 required." so, I tried the same steps using the last version found on the: http://coppeliarobotics.com/ubuntuVersions.html; but it seems that the last version coincide with version 3.6.1.3 and I don´t know how to resolve this issue.

On the other hand, althought in this manual It says nothing about changing the folder name "vrep_ros_interface", I also did it.

Please, I hope you could find a solution because I really needed to use it.

Thanks in advanced.

fferri
Posts: 344
Joined: 09 Sep 2013, 19:28

Re: How connect VREP & ROS Kinetic

Post by fferri » 18 May 2019, 12:37

V-REP 3.6.1 rev4 has not been released yet.

If you don't want to wait for it to be released, you have two options:
  • use an older version of the RosInterface plugin, e.g.: 88b8df0
  • build the latest version of V-REP (from the git repositories: v_rep, v_repClientApplication, include, common)

fferri
Posts: 344
Joined: 09 Sep 2013, 19:28

Re: How connect VREP & ROS Kinetic

Post by fferri » 21 May 2019, 12:01

This problem has been fixed.

You can now compile the latest RosInterface plugin with V-REP 3.6.1.rev2 or newer.

Cheers

Matheus
Posts: 8
Joined: 13 Apr 2019, 13:24

Re: How connect VREP & ROS Kinetic

Post by Matheus » 23 May 2019, 21:17

It worked!

Thanks a lot!

Post Reply