ROS Tutorial HELP !

Typically: "How do I... ", "How can I... " questions
pr0t0z
Posts: 19
Joined: 21 Nov 2014, 17:29

ROS Tutorial HELP !

Post by pr0t0z » 24 Nov 2014, 16:52

Hello community,

I am quite the fresh starter with v-rep, and I am digging my way through tutorials, to get a general idea.
I am using ROS Indigo, but the ROS tutorial I could find for v-rep was from Hydro. So I eventually found out that Indigo is not yet supported by v-rep. Going back to ROS Hydro would bit a bit of a problem for me though.

Anyhow! My problem is at the point where I open the "controlTypeExamples.ttt" scene, and at this moment I am only interested in the RED ROBOT!
So:
1) roscore is running;
2) vrep_plugin loads fine;

yet when I start the simulation, the red robot does not move :(
The node seems to be up, but there are no topics related to /robBubbleRob like in the tutorial.

Code: Select all

$ rosnode list
/rosBubbleRob8798177
/rosout
/vrep

Code: Select all

$ rostopic list
/rosout
/rosout_agg
/tf
/vrep/addStatusbarMessage
/vrep/info
/vrep/objectCount
roswtf output

Code: Select all

ERROR Could not contact the following nodes:
 * /rosBubbleRob8798177

ERROR The following nodes should be connected but aren't:
 * /rosBubbleRob8798177->/rosout (/rosout)

ERROR Errors connecting to the following services:
 * service [/rosBubbleRob8798177/get_loggers] appears to be malfunctioning: Unable to communicate with service [/rosBubbleRob8798177/get_loggers], address [rosrpc://machine1:51085]
 * service [/rosBubbleRob8798177/set_logger_level] appears to be malfunctioning: Unable to communicate with service [/rosBubbleRob8798177/set_logger_level], address [rosrpc://machine1:51085]
I tried looking in the forum for related issues and found nothing. Can you tell me what is going on?
Is there a way to debug the source code at ros_bubble_rob?

Newb questions all over! Sorry if there is anything obvious I am missing!

coppelia
Site Admin
Posts: 7267
Joined: 14 Dec 2012, 00:25

Re: ROS Tutorial HELP !

Post by coppelia » 25 Nov 2014, 00:15

Hello,

when using ROS Indigo, have a look at this post. Also, make sure to recompile the ROS plugin (and it is also probably safer to also recompile the rosBubbleRob executable, since this is what the red robot uses for control).

Cheers

sloppy
Posts: 5
Joined: 25 Nov 2014, 09:57

Re: ROS Tutorial HELP !

Post by sloppy » 26 Nov 2014, 10:46

I also have been having trouble with the ROS tutorial, trying to follow along the Hydro tutorial but using ROS Indigo (on Ubuntu 14.04 which doesn't support Hydro). I cannot call any services. I tried recompiling the plugin following the instructions in the link you mentioned, but that hasn't fixed my problem. "rosservice list" works fine, but for all the service calls I've tried, I get this same error:

Code: Select all

rosservice call /vrep/simRosStartSimulation 
ERROR: Unable to load type [vrep_common/simRosStartSimulation].
Have you typed 'make' in [vrep_common]?
For the scene "controlTypeExamples.ttt", I also get all the same outputs as was given in the first post from "rostopic list" and "roswtf".

The plugin does work for a good portion of the tutorial though. I had roscore is running, roscd finds all the vrep packages, and when I launched V-REP, I had output "Plugin 'Ros': load succeeded."The rostopic publishers and subscribers were working fine for me in "rosTopicPublisherAndSubscriber.ttt." In the control type example, the banner "I am controlled via a ROS node! ('rosBubbleRob' controlls me)" comes up fine.

I know ROS Indigo isn't officially supported by V-REP yet, but are there any other fixes I can try?

pr0t0z
Posts: 19
Joined: 21 Nov 2014, 17:29

Re: ROS Tutorial HELP !

Post by pr0t0z » 26 Nov 2014, 19:47

Hello!

I went for the easy way around. Got a fresh start in 12.04 with ros-hydro and things go smoothly. I'm trying to put together a simple robot control over ros, although I am an early starter, so I figured I should start on the most stable platforms I could find. :)

Cheers

Laurie44
Posts: 6
Joined: 09 Jan 2015, 17:18

Re: ROS Tutorial HELP !

Post by Laurie44 » 09 Jan 2015, 20:04

Hi there,

I am experiencing the same issues as pr0t0z "There are no topics related to /robBubbleRob like in the tutorial". Roswtf, rostopic and rosnode give me the same results. Is there any update/solution on this particular problem, other than recompile ROS?

And, when does Indigo will be fully supported?

Thanks a lot for your time.

coppelia
Site Admin
Posts: 7267
Joined: 14 Dec 2012, 00:25

Re: ROS Tutorial HELP !

Post by coppelia » 10 Jan 2015, 00:12

Hello,

have you tried to recompile the V-REP ROS plugin? You very probably will not come around that.

ROS Indigo should then work. Officially we are however not yet supporting it (since we haven't really tested it thoughouly), but probably very soon.

Cheers

pr0t0z
Posts: 19
Joined: 21 Nov 2014, 17:29

Re: ROS Tutorial HELP !

Post by pr0t0z » 12 Jan 2015, 23:29

Hi there,

So I have recently resumed my struggle in VRep-ROS, and strangely I came back to this very same problem. I am trying something very basic, yet I am having the same problem. I just modified the "controlTypeExamples.ttt" script for the ROS controlled mobile robot to a 7 DoF kuka manipulator. I also modified the control code "rosBubbleRob.cpp".

For simplification, I am just trying to read and send commands to a single joint. Here is the control code if you want to take a look:

https://www.dropbox.com/s/fw4mm9m8yd4hu ... l.cpp?dl=0

When I run the simulation, I am able to read the JointState, but cannot send any move commands.
Here is some more additional information.

Code: Select all

$ rosnode list
/control4381955
/rosout
/vrep

Code: Select all

$ rostopic list
/control4381955/joints
/rosout
/rosout_agg
/tf
/vrep/addStatusbarMessage
/vrep/info
/vrep/objectCount
/vrep/readJointState4381955
From roswtf:

Code: Select all

Found 2 warning(s).
Warnings are things that may be just fine, but are sometimes at fault

WARNING The following node subscriptions are unconnected:
 * /vrep:
   * /vrep/addStatusbarMessage

WARNING No tf messages

Found 3 error(s).

ERROR Could not contact the following nodes:
 * /control4381955

ERROR The following nodes should be connected but aren't:
 * /control4381955->/vrep (/control4381955/joints)
 * /vrep->/control4381955 (/vrep/readJointState4381955)
 * /vrep->/control4381955 (/vrep/info)
 * /control4381955->/rosout (/rosout)

ERROR Errors connecting to the following services:
 * service [/control4381955/set_logger_level] appears to be malfunctioning: Unable to communicate with service [/control4381955/set_logger_level], address [rosrpc://cpc:44162]
 * service [/control4381955/get_loggers] appears to be malfunctioning: Unable to communicate with service [/control4381955/get_loggers], address [rosrpc://cpc:44162]
Tried recompiling the vrep ros plugin, and the same error persists. I am a bit clueless, would appreciate if anyone could shed some light!

Thanks in advance for your time!
Regards,
Carlos

coppelia
Site Admin
Posts: 7267
Joined: 14 Dec 2012, 00:25

Re: ROS Tutorial HELP !

Post by coppelia » 13 Jan 2015, 11:43

Hello Carlos,

can you try to recompile the RosBubbleRob project by adding following to the CMakeLists.txt:

Code: Select all

link_directories("/opt/ros/indigo/lib")
link_directories("/opt/ros/hydro/lib")
Or for that matter, slightly adjust that file in a similar way as was done with the CMakeLists.txt for the vrep_plugin package?

Cheers

pr0t0z
Posts: 19
Joined: 21 Nov 2014, 17:29

Re: ROS Tutorial HELP !

Post by pr0t0z » 13 Jan 2015, 13:30

Hello,

So I tried tweaking the CMakeList.txt by adding those lines, but nothing has changed:
http://pastebin.com/t1Pkv21W

Last time I forgot to paste the beginning of the roswtf output. So here it is:

Code: Select all

$ roswtf
Loaded plugin tf.tfwtf
No package or stack in context
================================================================================
Static checks summary:

No errors or warnings
================================================================================
Beginning tests of your ROS graph. These may take awhile...
analyzing graph...
... done analyzing graph
running graph rules...
ERROR: connection refused to [http://cpc:51015/]
... done running graph rules
running tf checks, this will take a second...
... tf checks complete
This seems to be related to Network configuration (ERROR: connection refused to [http://cpc:51015/]), but I don't understand how does it work for the rosBubbleRob example, if the configuration is the same.

roswtf output of rosBubbleRob:

Code: Select all

$ roswtf
Loaded plugin tf.tfwtf
No package or stack in context
================================================================================
Static checks summary:

No errors or warnings
================================================================================
Beginning tests of your ROS graph. These may take awhile...
analyzing graph...
... done analyzing graph
running graph rules...
... done running graph rules
running tf checks, this will take a second...
... tf checks complete

Online checks summary:

Found 1 warning(s).
Warnings are things that may be just fine, but are sometimes at fault

WARNING No tf messages
This is driving me mad :S

Cheers!
Carlos

pr0t0z
Posts: 19
Joined: 21 Nov 2014, 17:29

Re: ROS Tutorial HELP !

Post by pr0t0z » 13 Jan 2015, 17:28

Ok, problem was in:

Code: Select all

msg.handles.data[0]=jointHandle;
msg.setModes.data[0]=2; // 2 is the speed mode
msg.values.data[0]=desiredJoint1Velocity;
jointStatePub.publish(msg)

Code: Select all

msg.handles.data.push_back(jointHandle);
msg.setModes.data.push_back(2); // 2 is the speed mode
msg.values.data.push_back(desiredJoint1Velocity);
jointStatePub.publish(msg);
Nodes connect fine now.

Post Reply