unset "invert target velocity at limits"

Typically: "How do I... ", "How can I... " questions
Post Reply
mfloyd
Posts: 21
Joined: 29 Oct 2014, 23:06

unset "invert target velocity at limits"

Post by mfloyd » 31 Jul 2015, 23:35

I create some non-hybrid motion mode joints through a script. The default setting is "Invert target velocity at limits". Is there a way to unset this property after creating the joint in the script?

When I copy a dynamic model and change the joints to comparable static choices I run into the following situation: A torque/force controlled joint that is motor enabled, but not control loop enabled is velocity controlled and best replaced with a motion controlled non-hybrid joint since it is the only velocity controlled static joint option I am aware of. But when I do that the static joint does not stop at the limits the same way as the joint it is meant to replace.

coppelia
Site Admin
Posts: 7441
Joined: 14 Dec 2012, 00:25

Re: unset "invert target velocity at limits"

Post by coppelia » 03 Aug 2015, 16:39

Hello,

the motion mode of a joint should be used with care, since it is not that flexible and more of a remnant of older V-REP versions. Best would be to set your joint in passive mode and to control it via a child script (i.e. update its position appropriately in each simulation loop). Then you would be in full control of what your joint is doing. The simplest child script to make your joint move (non-dynamically) would be to increment its position in each simulation step: your joint would have a constant speed. You could then add some acceleration/etc. as you need.

Cheers

mfloyd
Posts: 21
Joined: 29 Oct 2014, 23:06

Re: unset "invert target velocity at limits"

Post by mfloyd » 03 Aug 2015, 23:57

Thanks. That's good to know that the motion mode is outdated. I implemented the static model velocity control as suggested and it works great.

Post Reply