RosInterface Loading Error

Typically: "How do I... ", "How can I... " questions
Post Reply
Posts: 1
Joined: 24 Oct 2016, 05:56

RosInterface Loading Error

Post by olivia » 24 Oct 2016, 07:59

I installed VREP version 3.3.2 edu and indigo on Ubuntu 14.04 and was trying to interface between the two.
After compiling the plugins as in ... Indigo.htm using catkin tool(there were some bugs "can't find .h .cpp files", so I copied those files from vrep/programming/common and build the workspace successfully), I copied file to V-rep installation directory and opened roscore then start v-rep.
The following error appears.
Plugin 'RosInterface': loading...
[FATAL] [1477291636.529911605]: ROS_MASTER_URI is not defined in the environment. Either type the following or (preferrably) add this to your ~/.bashrc file in order set up your local machine as a ROS master:

export ROS_MASTER_URI=http://localhost:11311

then, type 'roscore' in another shell to actually launch the master program.
I tried
1. copy exactly that line into .bashrc, reopen terminal and run roscore and start vrep, but the same error appears. if I type
echo $ROS_MASTER_URI, output is http://localhost:11311/, which I guess is to be expected.
2. type that line in the terminal and start vrep again, same error appears.

I am new to ROS and VREP so I don't know what happened. Any help is appreciated! Thanks.

reinstalled ROS and tried starting vrep, it was smooth for the first time. But after I quitted vrep and started again, the same error appeared..

run vrep without sudo would work

Post Reply