Plugin RosInterface not loading

Typically: "How do I... ", "How can I... " questions
Post Reply
e2718
Posts: 14
Joined: 15 Nov 2015, 05:39

Plugin RosInterface not loading

Post by e2718 » 10 Sep 2017, 19:14

have been having trying to get RosInterface loaded. Am currently following the Indigo tutorial located here:
http://www.coppeliarobotics.com/helpFil ... ndigo.html.

My problem is I can't seem to get the ros plugin 'RosInterface' to load. I know the packages have installed because calling roscd works. Would like help debugging what went wrong. Have attached the terminal outputs of what I see

Code: Select all

# can find the package rosinterface with roscd
humanoid@toughbook:~/catkin_ws/src$ roscd vrep_ros_interface
humanoid@toughbook:~/catkin_ws/src/v_repExtRosInterface$

Code: Select all

# separate tab run roscore
humanoid@toughbook:~$ roscore
... logging to /home/humanoid/.ros/log/943e238c-9653-11e7-bc0e-20c6eb68f2d5/roslaunch-toughbook-22979.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://toughbook.local:33202/
ros_comm version 1.11.21


SUMMARY
========

PARAMETERS
 * /rosdistro: indigo
 * /rosversion: 1.11.21

NODES

auto-starting new master
process[master]: started with pid [22991]
ROS_MASTER_URI=http://toughbook.local:11311/

setting /run_id to 943e238c-9653-11e7-bc0e-20c6eb68f2d5
process[rosout-1]: started with pid [23005]
started core service [/rosout]

Code: Select all

# when running V-REP, can not find 'RosInterface'
humanoid@toughbook:~/catkin_ws/src/v_repExtRosInterface$ cd $VREP_ROOT
humanoid@toughbook:~/V-REP_PRO_EDU_V3_4_0_Linux$ ./vrep.sh
Using the default Lua library.
Loaded the video compression library.
Add-on script 'vrepAddOnScript-addOnScriptDemo.lua' was loaded.
QSplitter::setCollapsible: Index 0 out of range
Simulator launched.
Plugin 'MeshCalc': loading...
Plugin 'MeshCalc': load succeeded.
Plugin 'BubbleRob': loading...
Plugin 'BubbleRob': load succeeded.
Plugin 'Bwf': loading...
Plugin 'Bwf': load succeeded.
Plugin 'Collada': loading...
Plugin 'Collada': load succeeded.
Plugin 'ConvexDecompose': loading...
Plugin 'ConvexDecompose': load succeeded.
Plugin 'CustomUI': loading...
Plugin 'CustomUI': load succeeded.
Plugin 'DynamicsBullet-2-78': loading...
Plugin 'DynamicsBullet-2-78': load succeeded.
Plugin 'DynamicsBullet-2-83': loading...
Plugin 'DynamicsBullet-2-83': load succeeded.
Plugin 'DynamicsNewton': loading...
Plugin 'DynamicsNewton': load succeeded.
Plugin 'DynamicsOde': loading...
Plugin 'DynamicsOde': load succeeded.
Plugin 'DynamicsVortex': loading...
Plugin 'DynamicsVortex': load succeeded.
Plugin 'ExternalRenderer': loading...
Plugin 'ExternalRenderer': load succeeded.
Plugin 'K3': loading...
Plugin 'K3': load succeeded.
Plugin 'LuaRemoteApiClient': loading...
Plugin 'LuaRemoteApiClient': load succeeded.
Plugin 'Mtb': loading...
Plugin 'Mtb': load succeeded.
Plugin 'OMPL': loading...
Plugin 'OMPL': load succeeded.
Plugin 'OpenMesh': loading...
Plugin 'OpenMesh': load succeeded.
Plugin 'PovRay': loading...
Plugin 'PovRay': load succeeded.
Plugin 'Qhull': loading...
Plugin 'Qhull': load succeeded.
Plugin 'RRS1': loading...
Plugin 'RRS1': load succeeded.
Plugin 'ReflexxesTypeII': loading...
Plugin 'ReflexxesTypeII': load succeeded.
Plugin 'RemoteApi': loading...
Starting a remote API server on port 19997
Plugin 'RemoteApi': load succeeded.
Plugin 'SDF': loading...
Plugin 'SDF': load succeeded.
Plugin 'SimpleFilter': loading...
Plugin 'SimpleFilter': load succeeded.
Plugin 'SurfaceReconstruction': loading...
Plugin 'SurfaceReconstruction': load succeeded.
Plugin 'Urdf-a': loading...
Plugin 'Urdf-a': load succeeded.
Plugin 'Urdf': loading...
Plugin 'Urdf': load succeeded.
Plugin 'Vision': loading...
Plugin 'Vision': load succeeded.
Using the 'MeshCalc' plugin.



e2718
Posts: 14
Joined: 15 Nov 2015, 05:39

Re: Plugin RosInterface not loading

Post by e2718 » 10 Sep 2017, 23:14

Forgot to mention have tried putting the files from the catkin_ws/src into both the $VREP_ROOT directory and the $VREP_ROOT/programming directory and get the same result.

coppelia
Site Admin
Posts: 6183
Joined: 14 Dec 2012, 00:25

Re: Plugin RosInterface not loading

Post by coppelia » 12 Sep 2017, 14:42

Hello,

it seems that V-REP isn't even trying to load the rosInterface. Are you sure you placed it in the V-REP folder? Are you sure its name is v_repExtRosInterface.so?

Cheers

Post Reply