Page 1 of 1

Problem with remoteApi.dll

Posted: 07 Dec 2017, 18:15
by martin

I've worked with VREP many times, and I still can do it. But now a colleague has started to use the VREP too and we've found a problem.

We share a folder which we work on the same program. It consist of an VREP scene, and a Python project. We use the external Python API for controlling our robot on VREP.

Both of us have installed the VREP version 3.4.0 64 bits (serialization 20). I use python 2.7.12 through Anaconda and my colleague python 2.7.13 with Anaconda too and both of us have a Windows 10 installed.

In the folder we shared, we have the following files:

- remoteApi.dll

The problem arise when, having the same files, the "remoteApi.dll" that I have to use is different from the "remoteApi.dll" that my colleague use. My colleague use the file that is contained in "\programming\remoteApiBindings\lib\lib\64Bit". The file that she has there is the same that I have on my PC on the same directory. However, if I use that file, I cannot run the Python program we develop, I have to use an old version of this file which I "inherit" from my previuos proyects and which works fine for me.

The remoteApi.dll file I use is 128KB weight and while my colleage's file is 66KB

Any suggestion about what can be happening?


Re: Problem with remoteApi.dll

Posted: 10 Dec 2017, 21:40
by coppelia

during the installation procedure, did you make sure to install the MSVC2015 redistributables? Normally yes, otherwise you should not be able to run version 3.4.0... then the problem is probably something else.
Is there any error output from Python when you try to run the program? DO the other dll from your colleague work on your machine?

You can always try to recompile the remote API lib yourself (for that, make sure to use a 64bit compiler, if your Python is really 64bit).


Re: Problem with remoteApi.dll

Posted: 12 Dec 2017, 10:19
by Manon
As I said in viewtopic.php?f=5&t=6705 , I found out that that 64bits version of remoteApi.dll fails, while the 32bits works on my 64bits windows 10 computer (but I just started working o vrep, so I'm not sure everything works).

There was an exeption at line

libsimx = ct.CDLL(libfullpath)

(or the next one) with ctypes complaining about something not being 32bits (sorry I didn't save the exception).

But changing the dll solved the problem (so far).

Re: Problem with remoteApi.dll

Posted: 17 Dec 2017, 17:38
by coppelia
Whether you need to select the 32 or 64 bit remote api dll is not linked to the processor architecture. It is linked to the type of application your Python is. Is it the 32bit version of Python, or the 64bit version?