[Hexapod] Too many objects to add in collision check

Typically: "How do I... ", "How can I... " questions
ravi
Posts: 73
Joined: 24 Oct 2016, 08:00

Re: [Hexapod] Too many objects to add in collision check

Post by ravi » 05 Mar 2018, 14:59

coppelia wrote:
05 Mar 2018, 07:28
Each motor's black axis will collide with the robot's white shapes.
yes, you are right. I noticed it.
coppelia wrote:
05 Mar 2018, 07:28
You either need to modify the shapes, or shift them a little bit until they do not collide anymore.
Please see the attached screenshot below:
https://www.dropbox.com/s/dij965tk941u5 ... t.png?dl=0

I think that if I can cut the highlighted portion (in orange color) from each motor, the problem can be solved. However, I don't see any option to select and modify/cut some part of a compound shape.

See the scene file below:
https://www.dropbox.com/s/ov0hud9gdpqtv ... 2.ttt?dl=0

What do you suggest?

coppelia
Site Admin
Posts: 6625
Joined: 14 Dec 2012, 00:25

Re: [Hexapod] Too many objects to add in collision check

Post by coppelia » 06 Mar 2018, 09:09

You have 2 possibilities:
  • decompose compound shapes, edit the component, regroup the compound shape. This is quite troublesome.
  • simply attach auxiliary cuboid shapes to each motor. Make them invisible. Then use the cuboid shapes instead of the motor shapes in the collection
Cheers

ravi
Posts: 73
Joined: 24 Oct 2016, 08:00

Re: [Hexapod] Too many objects to add in collision check

Post by ravi » 08 Mar 2018, 11:01

Thank you very much.

I simply removed all the motors. the model looks weird but working!

Post Reply