Robot cannot move along a planning path with IK

Typically: "How do I... ", "How can I... " questions
Post Reply
Zhuang
Posts: 21
Joined: 02 Aug 2017, 14:43

Robot cannot move along a planning path with IK

Post by Zhuang » 11 Mar 2018, 10:02

Hello,
Recently, I am learning Inverse kinematics with Vrep. I try to learning it by imitating motionPlanningAndGraspingDemo.ttt & motionPlanningServerDemo.ttt . But my robot can not move all the time. I carefully check those differences between my project and the former Demo. I have spend several days on looking for bugs. But I do not succeed .
I do not know why the robot_target move(it should stay the initial position ) and why the robot does not move.
There is my scenes(test_two.ttt):https://www.dropbox.com/s/tbcj892m9g6gq ... o.ttt?dl=0

thank you
Zhuang

coppelia
Site Admin
Posts: 6747
Joined: 14 Dec 2012, 00:25

Re: Robot cannot move along a planning path with IK

Post by coppelia » 12 Mar 2018, 07:38

Hello,

debugging that kind of scene is quite difficult, since it requires to perfectly know the purpose of the application, and all the scripts involved. The best pointers I can give you are following when a path planning task is not working as expected:
  • Make sure the desired robot pose is reachable
  • Make sure the desired robot configuration does not lie outside of the joint limits
  • Make sure the robot is not potentially colliding with itself
  • Make sure the robot does not collide with the environment in the end-pose/configuration
  • Make sure the path planning algorithm is appropriate
  • Make sure the path planning parameters are appropriate
  • At first, always try to use path planning without collision detection, for debugging purposes
Cheers

Zhuang
Posts: 21
Joined: 02 Aug 2017, 14:43

Re: Robot cannot move along a planning path with IK

Post by Zhuang » 12 Mar 2018, 12:30

coppelia wrote:
12 Mar 2018, 07:38
Hello,

debugging that kind of scene is quite difficult, since it requires to perfectly know the purpose of the application, and all the scripts involved. The best pointers I can give you are following when a path planning task is not working as expected:
  • Make sure the desired robot pose is reachable
  • Make sure the desired robot configuration does not lie outside of the joint limits
  • Make sure the robot is not potentially colliding with itself
  • Make sure the robot does not collide with the environment in the end-pose/configuration
  • Make sure the path planning algorithm is appropriate
  • Make sure the path planning parameters are appropriate
  • At first, always try to use path planning without collision detection, for debugging purposes
Cheers
Hello,coppelia
Thank you for your effective answer.

I will try my best to read and understand them in terms of code about all the scripts, but I am worried that there are some mistakes of the Robot configuration in Vrep. I have checked many times but i still think there are some mistakes.

Cheers

Zhuang
Posts: 21
Joined: 02 Aug 2017, 14:43

Re: Robot cannot move along a planning path with IK

Post by Zhuang » 13 Mar 2018, 11:41

coppelia wrote:
12 Mar 2018, 07:38
Hello,

debugging that kind of scene is quite difficult, since it requires to perfectly know the purpose of the application, and all the scripts involved. The best pointers I can give you are following when a path planning task is not working as expected:
  • Make sure the desired robot pose is reachable
  • Make sure the desired robot configuration does not lie outside of the joint limits
  • Make sure the robot is not potentially colliding with itself
  • Make sure the robot does not collide with the environment in the end-pose/configuration
  • Make sure the path planning algorithm is appropriate
  • Make sure the path planning parameters are appropriate
  • At first, always try to use path planning without collision detection, for debugging purposes
Cheers
Hi, coppelia
I try to use Simple Variable Method to find those problems. I copy the robot Jaco in motionPlanningAndGraspingDemo.ttt to a very sample sense. Yes , it works. And the I delete the robot and built a same Jaco robot with the same code. I set those parameters like IK grope, joints, collection. i tried my best to make them the same, the same code, goals, location. But the robot i built does not work. yes, i think the configurations are wrong. As mentioned earlier, I try to find the differences.And I still failed. I hope you can help me point the differences. Thank u
my sense is there(hello.ttt cannot work; hello_ok.ttt can do.):https://www.dropbox.com/sh/30w3tydrr0jq ... MPiia?dl=0

Cheers

coppelia
Site Admin
Posts: 6747
Joined: 14 Dec 2012, 00:25

Re: Robot cannot move along a planning path with IK

Post by coppelia » 14 Mar 2018, 07:37

You need to identify what part is not working. Which part is failing in the code?

So I looked into it, and it seems that sim.getConfigForTipPose, from findCollisionFreeConfig, from findSeveralCollisionFreeConfigs is not producing any result. This has two reasons:

1. Your robot is self-colliding in the second scene. Create a collision object that has as items collection Jaco vs Collection Jaco and you'll see the robot turning red. Enabled collision contour display to see where it is colliding.
2. Your Jaco_ik is different in the second scene: in the first you have specified only positional constraints, in the second scene you have also specified orientational constraints.

Cheers

Zhuang
Posts: 21
Joined: 02 Aug 2017, 14:43

Re: Robot cannot move along a planning path with IK

Post by Zhuang » 14 Mar 2018, 13:41

Hello,copplia
thank you for your reply.
it works. Vrep is very High-precision. I underestimated its accuracy. Thank you
Cheers

Post Reply