recording Video crashes

Typically: "How do I... ", "How can I... " questions
Post Reply
vrepUser94
Posts: 9
Joined: 08 Jan 2018, 08:41

recording Video crashes

Post by vrepUser94 » 21 Mar 2018, 07:36

Hello,

recently some problem with the V-REP internal video recorder occurred.

Although everything has already worked well, I suddenly get an error "The video compressor failed initializing. Check the console for additional messages."

I don't really get any further information what the error comes from.
Actually the recorder is working when I start it "manually", but when I start it from a customization script (with sim.setBoolParameter(sim.boolparam_video_recording_triggered,1)), which is the wanted way in my case, the error occurs.

I have never had this problem before, so I have no idea how to solve the issue.
Thanks for your help

coppelia
Site Admin
Posts: 7396
Joined: 14 Dec 2012, 00:25

Re: recording Video crashes

Post by coppelia » 21 Mar 2018, 11:53

Hello,

I cannot reproduce your crash. Please confirm that following crashes:
  • create an empty scene
  • add a customization script to an object
  • in the init phase of the customization script, add sim.setBoolParameter(sim.boolparam_video_recording_triggered,1)
  • run the simulation
Did you try to use a different video encoder type?

Cheers

vrepUser94
Posts: 9
Joined: 08 Jan 2018, 08:41

Re: recording Video crashes

Post by vrepUser94 » 22 Mar 2018, 15:43

Hello again,

thanks for your answer!

I don't really know what happened, but the error is suddenly gone, although the whole setup of my simulation is the same.
Maybe the old-fashioned method of shutting down the computer and restarting it today helped ;)

If the error occurs again I'll catch necessary information for debugging.

Thanks for the quick and perfect support you give all the time by the way.

Cheers

Post Reply