How to install vrep version 3.5 in ubuntu 14.04 LTS?

Typically: "How do I... ", "How can I... " questions
gendibal784
Posts: 7
Joined: 15 Mar 2018, 23:26

How to install vrep version 3.5 in ubuntu 14.04 LTS?

Post by gendibal784 » 23 Mar 2018, 18:38

I'm trying to use vrep to simulate youbot KUKA. I'm using a kinect as my vision sensor and I'm having problems to use the package "depthimage_to_laserscan" in ROS. The problem is that this package doesn't work with rgb8 images, which is the encoding that vrep is sending. I was looking for solutions to solve this problem and i found the following post, viewtopic.php?f=9&t=5916, which says that with the plugin "RosInterface", I could solve my problem.
However, I installed this plugin and moved the RosInterface library to my vrep's installation place but it didn't work because my vrep version is 3.4 rev1 and this plugin says that only works for 3.4 rev9 or above. I'm using ubuntu 14.04 and I can't update to 16.04 version because I work with ROS Indigo so, Is there any way to install the last version of vrep in ubuntu 14.04? If not, is there another way to solve this problem?

Thank you very much.

fferri
Posts: 219
Joined: 09 Sep 2013, 19:28

Re: How to install vrep version 3.5 in ubuntu 14.04 LTS?

Post by fferri » 23 Mar 2018, 20:50

Maybe this post can be helpful.

gendibal784
Posts: 7
Joined: 15 Mar 2018, 23:26

Re: How to install vrep version 3.5 in ubuntu 14.04 LTS?

Post by gendibal784 » 04 Apr 2018, 12:47

Thanks, I think this post will be my solution but I'm having problems with compiling vrep by myself because I don't know how to do that. I'm trying to follow this page http://www.coppeliarobotics.com/helpFil ... ngVrep.htm to use one of your solutions you said on the post you sent to me and i have this strucuture: My problem is that I don't know what commands I should use or what files I should run to compile and install this files to be able to launch vrep. Besides, could I use the programming folder from the V-REP 3.5.0 installation instead of creating a new one like I did?

Thanks for the previous reply and sorry if this could be a stupid question.

fferri
Posts: 219
Joined: 09 Sep 2013, 19:28

Re: How to install vrep version 3.5 in ubuntu 14.04 LTS?

Post by fferri » 05 Apr 2018, 10:20

Repositories with a .pro file need to be built with qmake (from Qt) and make.

Note that the dynamics plugin has several .pro files in the subdirectories, so you have to enter each subdirectory and run qmake and then make.

In your directory structure you also need to clone https://github.com/CoppeliaRobotics/v_r ... pplication under the programming directory, that would be the main executable.

Any other files you can take them from the V-REP release, mirroring its structure, but put the build products from above steps to their correct location.

gendibal784
Posts: 7
Joined: 15 Mar 2018, 23:26

Re: How to install vrep version 3.5 in ubuntu 14.04 LTS?

Post by gendibal784 » 13 Apr 2018, 12:32

hi again, these days I was trying to compile and install this files and I'm having problems with the installation of vrep's source code. First I qmake v_rep.pro and after that i use make to compile the makefile that has already been created but this operation send me an error which is:

make[1]: *** [release/luaWrapper.o] Error 1
make[1]: se sale del directorio «/home/youbot/Documentos/vrep_installation/pruebas2/vrep/v_rep»
make: *** [release] Error 2

I searched this file and it doesn't exist and I think this is something related with my configuration of config.pri that is:

BOOST_INCLUDEPATH = "/usr/local/include"
LUA_INCLUDEPATH = "../../lua-5.3.4/install/include"
LUA_LIBS = -L"../../lua-5.3.4/install/" -llua5.3
QSCINTILLA_DIR = "../../QScintilla_gpl-2.10.3"
QSCINTILLA_INCLUDEPATH = "$${QSCINTILLA_DIR}/include" "$${QSCINTILLA_DIR}/Qt4Qt5"
QSCINTILLA_LIBS = "$${QSCINTILLA_DIR}/Qt4Qt5/libqscintilla2_qt5.so"
exists(../config.pri) { include(../config.pri) }

I installed locally lua and his folder is ../../lua-5.3.4/install as you can read above and for QScintilla i just download it from their page and i used qmake and make linux install to compile and installing.

Thanks you for your fast answers, I really appreciate it

coppelia
Site Admin
Posts: 6766
Joined: 14 Dec 2012, 00:25

Re: How to install vrep version 3.5 in ubuntu 14.04 LTS?

Post by coppelia » 16 Apr 2018, 06:57

Hello,

as of now, Lua 5.1 is being used in V-REP.

Cheers

gendibal784
Posts: 7
Joined: 15 Mar 2018, 23:26

Re: How to install vrep version 3.5 in ubuntu 14.04 LTS?

Post by gendibal784 » 20 Apr 2018, 13:46

Thanks, I finally could compile vrep source code. After downloading the correct lua library I had problems with QScintilla2 but, at the end, I realised that the problem was my qmake version which was 5.4 instead of 5.9 or above.

After that, I compiled the Client application to be able to launch vrep but, when i open vrep, the program says that meshcal plugin isn't loaded and vrep is automatically killed when, for example, I try to click to load a scene, so I think I’m doing something wrong.

I'm using this structure, as i said before, and i have several questions: First of all, do I have to compile all plugins before vrep source code compiling (dynamicPlugin, meshCalculationPlugin and v_repClientApplication) or it doesn't matter? I tested to compile before and after this plugins but it didn't work when i launch ./vrep from v_repClientApplication. (perhaps do I have to modify something from this plugin before compiling? For example, I modified vrep.pro to include lua5.1.5)

Second, when I was compiling the subdirectories of dynamicsPlugin, I couldn't compile successfully v_repExtDynamicsBullet_2_83 and v_repExtDynamicsVortex. On the first one, it seems that the header btBulletDynamicsCommon.h doesn't exist and, on the second one, the header Vx/VxGearRatio.h doesn't neither exist. The other subfolders were compiled successfully.

And the last one, I was following the readme of v_rep source code but according to your post "compiling vrep" you said I have to put this folders inside vrep pro edu folder, which I can download from here http://www.coppeliarobotics.com/downloads.html. You said "V-REP compiles to a shared library" and I don't understand this very well, Is shared library the files that appear after compiling vrep source code? should I copy vrep source code into some place of vrep pro edu and replace some files? what do I have to do with vrep source code?

Thanks for all your answers.

gendibal784
Posts: 7
Joined: 15 Mar 2018, 23:26

Re: How to install vrep version 3.5 in ubuntu 14.04 LTS?

Post by gendibal784 » 23 Apr 2018, 18:53

when I try to load some file in vrep, the system give me this error and I don't really know the reason
Error: signal 11:
/home/youbot/Documentos/vrep_installation/V-REP_PRO_EDU_V3_5_0_Linux/libv_rep.so(_Z11_segHandleri+0x18)[0x7f1f747cc5e8]
/lib/x86_64-linux-gnu/libc.so.6(+0x36cb0)[0x7f1f787e3cb0]
/usr/lib/x86_64-linux-gnu/libgtk-3.so.0(+0x155526)[0x7f1f673ca526]
/usr/lib/x86_64-linux-gnu/libgtk-3.so.0(+0x15c62e)[0x7f1f673d162e]
/usr/lib/x86_64-linux-gnu/libgio-2.0.so.0(+0x808db)[0x7f1f66ab98db]
/usr/lib/x86_64-linux-gnu/libgio-2.0.so.0(+0x808f9)[0x7f1f66ab98f9]
/lib/x86_64-linux-gnu/libglib-2.0.so.0(g_main_context_dispatch+0x135)[0x7f1f7556ece5]
/lib/x86_64-linux-gnu/libglib-2.0.so.0(+0x49048)[0x7f1f7556f048]
/lib/x86_64-linux-gnu/libglib-2.0.so.0(g_main_context_iteration+0x2c)[0x7f1f7556f0ec]
/home/youbot/Qt5.9.0/5.9/gcc_64/lib/libQt5Core.so.5(_ZN20QEventDispatcherGlib13processEventsE6QFlagsIN10QEventLoop17ProcessEventsFlagEE+0x5f)[0x7f1f793d293f]
QMutex: destroying locked mutex
QMutex: destroying locked mutex

coppelia
Site Admin
Posts: 6766
Joined: 14 Dec 2012, 00:25

Re: How to install vrep version 3.5 in ubuntu 14.04 LTS?

Post by coppelia » 24 Apr 2018, 07:27

In a first step, try to simply run V-REP naked (no plugins or other optional things).

This means, at first, you do not need the dynamics plugins nor the mesh calculation plugin.
When you compile V-REP source code, you obtain a library (v_rep.dll or similar). That one is loaded by the client application. But it can only be loaded if it finds all dependencies (e.g. lua, Qt, QScintilla). Did you compile QScintilla?

Cheers

gendibal784
Posts: 7
Joined: 15 Mar 2018, 23:26

Re: How to install vrep version 3.5 in ubuntu 14.04 LTS?

Post by gendibal784 » 24 Apr 2018, 18:16

Yes, I compiled locally lua and QScintilla in their folders. When I compile v_rep source code, I refer this libraries on the config.pri . I tried simply run V-REP with only libv_rep.so and it gave me the same error as above. I realised that V_REP PRO EDU also has libqscintilla2.so in its folder so I put it on my v_repClientApplication folder but the error is still the same.

Should I modify the vrep.pro of v_repClientApplication? I guess my v_repClientApplication can't find their dependencies but I don't know why and what i should modify in this script to solve this problem.

Thanks for your support, as always.

PD:When I refer to *.so, it means also the other files, for example, libv_rep.so, libv_rep.so.1, libv_rep.so.1.0 and libv_rep.so.1.0.0

Post Reply