Object Lagging behind parent during simulation

Typically: "How do I... ", "How can I... " questions
Post Reply
AHARR64
Posts: 7
Joined: 15 Nov 2018, 21:42

Object Lagging behind parent during simulation

Post by AHARR64 » 05 Feb 2019, 21:05

Hi,

I'm trying to simulate a robotic arm with a barretthand attached to the end, but during simulation the hand trails behind the arm during quick movements. Is there any way i can fix this besides slowing the speed that the arm moves?

I've attached a GIF of what the problem is.
https://gyazo.com/ea11d90eeb6eefb0d57fa91bbf3a07d0

Thanks in advance

coppelia
Site Admin
Posts: 7157
Joined: 14 Dec 2012, 00:25

Re: Object Lagging behind parent during simulation

Post by coppelia » 06 Feb 2019, 09:23

Hello,

this is perfectly normal, depending on the physics engine you use: your robot arm probably moves statically (i.e. is not dynamically enabled or simulated) but your gripper not (the gripper is dynamically enabled and simulated). So in case of large velocity, constraints start to break apart (again, the degree of breaking apart depends on the physics engine you use, and also the settings you use). You probably have several ways that you can reduce this lag: reduce the mass of the gripper (not such a good idea)or increase the constraint solving iterations.

Cheers

AHARR64
Posts: 7
Joined: 15 Nov 2018, 21:42

Re: Object Lagging behind parent during simulation

Post by AHARR64 » 07 Feb 2019, 03:44

Hi,

Turns out i had a static cylinder attached to the dynamic gripper - exactly what you said. When i removed the cylinder it worked perfectly. Thanks for the help!

Post Reply