On UR5 Motion Planning using OMPL

Typically: "How do I... ", "How can I... " questions
Post Reply
Posts: 8
Joined: 17 Apr 2017, 20:03

On UR5 Motion Planning using OMPL

Post by mohtashem » 15 Feb 2019, 12:53


I tried using the motionPlanningDemo1 code for UR5. I've posted the scene here:
https://drive.google.com/file/d/11_Yrhl ... sp=sharing

I modified the necessary specs like collision pairs, ik group etc for UR5 so that I could use it like KUKA LBR in the original motionPlanningDemo1 scene. I however observed that on running the algorithm, quite often I get the following error:
Lua runtime error: [string "CHILD SCRIPT UR5_link1_visible"]:264: attempt to get length of local 'path' (a nil value)
stack traceback:
[string "CHILD SCRIPT UR5_link1_visible"]:264: in function 'getReversedPath'
[string "CHILD SCRIPT UR5_link1_visible"]:352: in function <[string "CHILD SCRIPT UR5_link1_visible"]:273>
I narrowed it down to the choice of Algorithm in OMPL. I tried all possible algorithms(including tweaking the parameters) mentioned on the website. Some of them do not generate a path at all, some generate a motion for some targets and fail for other targets.

In the ones that did work( e.g.TRRT, STRIDE, PDST), I observed that:

1. The robot the wrist moves intersecting the robot body itself to reach the target.

2. Sometimes the robot directly reaches the target, instead of first arriving at a point and then moving in a straight path towards the target. [I didn't make any changes to this part of the code i.e. getMatrixShiftedAlongZ() or generateIKPath() etc]

Any suggestions on how to fix it?

Additionally, kindly let me know if there is a simpler example of OMPL motion planning for a robot arm that one could learn from?

Best Regards,

Site Admin
Posts: 7255
Joined: 14 Dec 2012, 00:25

Re: On UR5 Motion Planning using OMPL

Post by coppelia » 20 Feb 2019, 13:37


it can be quite tricky to use the OMPL functions. At the same time, there used to be 1-2 bugs in that OMPL plugin, maybe you can try with the latest V-REP release (V3.6.0.rev1).


Post Reply