problem about new version coppeliaSim

Typically: "How do I... ", "How can I... " questions
Post Reply
jianye
Posts: 30
Joined: 16 Oct 2019, 13:58

problem about new version coppeliaSim

Post by jianye » 14 Dec 2019, 20:12

hello,

recently I download the coppeliaSim and replace the Vrep before.
But with the new version I can't open the scene I built before and I get the following problem in the terminal window:

terminate called after throwing an instance of 'boost::exception_detail::clone_impl<boost::exception_detail::error_info_injector<boost::io::bad_format_string> >'
what(): boost::bad_format_string: format-string is ill-formed
./coppeliaSim.sh: line 33: 11271 Aborted (core dumped) "$dirname/$appname" "${PARAMETERS[@]}"


any advice ?

Thank you in advance

Jian

coppelia
Site Admin
Posts: 7527
Joined: 14 Dec 2012, 00:25

Re: problem about new version coppeliaSim

Post by coppelia » 18 Dec 2019, 22:56

Hello,

can you tell me exactly when the crash happens? Which platform are you on? With what version of V-REP did you last wrote the file? Can you post the file?

Cheers

Filipe Rocha
Posts: 11
Joined: 28 May 2017, 20:51

Re: problem about new version coppeliaSim

Post by Filipe Rocha » 08 Jan 2020, 20:45

Same problem here. I am not able to open a former scene from V-REP. I even exported only the robot model, but the problem persists.

The crash happens as I try to open the scene/model.
Last version of V-REP used: 3.6.2 (rev 0) 64 bits.
CoppeliaSim version: CoppeliaSim Edu V4.0.0. (rev. 1) 64 bits.
OS: Ubuntu 18.04

Here is the terminal output when the error occurs:

Code: Select all

❯ coppeliaSim
Loading the CoppeliaSim library...
Done!
Launching CoppeliaSim...
lib: 1
lic: 1

CoppeliaSim Edu V4.0.0. (rev. 1)
Using the default Lua library.
Loaded the video compression library.
Add-on script 'simAddOnScript-addOnScriptDemo.lua' was loaded.
Add-on script 'simAddOnScript-b0RemoteApiServer.lua' was loaded.
Add-on script 'simAddOnScript_PyRep.lua' was loaded.
If CoppeliaSim crashes now, try to install libgl1-mesa-dev on your system:
>sudo apt install libgl1-mesa-dev
OpenGL: NVIDIA Corporation, Renderer: GeForce GTX 1060/PCIe/SSE2, Version: 4.6.0 NVIDIA 435.21
...did not crash.
Simulator launched.
Plugin 'Geometric': loading...
Plugin 'Geometric': load succeeded.
Plugin 'Assimp': loading...
Plugin 'Assimp': warning: replaced variable 'simAssimp'
Plugin 'Assimp': load succeeded.
Plugin 'BlueZero': loading...
Plugin 'BlueZero': warning: replaced variable 'simB0'
Plugin 'BlueZero': load succeeded.
Plugin 'BubbleRob': loading...
Plugin 'BubbleRob': load succeeded.
Plugin 'Bwf': loading...
Plugin 'Bwf': load succeeded.
Plugin 'CodeEditor': loading...
Plugin 'CodeEditor': load succeeded.
Plugin 'Collada': loading...
Plugin 'Collada': load succeeded.
Plugin 'ConvexDecompose': loading...
Plugin 'ConvexDecompose': load succeeded.
Plugin 'CustomUI': loading...
Plugin 'CustomUI': warning: replaced variable 'simUI'
Plugin 'CustomUI': warning: replaced function 'simUI.insertTableRow@CustomUI'
Plugin 'CustomUI': warning: replaced function 'simUI.removeTableRow@CustomUI'
Plugin 'CustomUI': warning: replaced function 'simUI.insertTableColumn@CustomUI'
Plugin 'CustomUI': warning: replaced function 'simUI.removeTableColumn@CustomUI'
Plugin 'CustomUI': warning: replaced function 'simUI.setScene3DNodeParam@CustomUI'
Plugin 'CustomUI': load succeeded.
Plugin 'DynamicsBullet-2-78': loading...
Plugin 'DynamicsBullet-2-78': load succeeded.
Plugin 'DynamicsBullet-2-83': loadiere is the terminal output when the error occurs: ng...
Plugin 'DynamicsBullet-2-83': load succeeded.
Plugin 'DynamicsNewton': loading...
Plugin 'DynamicsNewton': load succeeded.
Plugin 'DynamicsOde': loading...
Plugin 'DynamicsOde': load succeeded.
Plugin 'DynamicsVortex': loading...
Plugin 'DynamicsVortex': load succeeded.
Plugin 'ExternalRenderer': loading...
Plugin 'ExternalRenderer': load succeeded.
Plugin 'ICP': loading...
Plugin 'ICP': warning: replaced variable 'simICP'
Plugin 'ICP': load succeeded.
Plugin 'Image': loading...
Plugin 'Image': warning: replaced variable 'simIM'
Plugin 'Image': load succeeded.
Plugin 'K3': loading...
Plugin 'K3': load succeeded.
Plugin 'Lic': loading...
Plugin 'Lic': load succeeded.
Plugin 'LuaCommander': loading...
Plugin 'LuaCommander': warning: replaced variable 'simLuaCmd'
Plugin 'LuaCommander': load succeeded.
Plugin 'LuaRemoteApiClient': loading...
Plugin 'LuaRemoteApiClient': load succeeded.
Plugin 'Mtb': loading...
Plugin 'Mtb': load succeeded.
Plugin 'OMPL': loading...
Plugin 'OMPL': warning: replaced variable 'simOMPL'
Plugin 'OMPL': load succeeded.
Plugin 'OpenGL3Renderer': loading...
Plugin 'OpenGL3Renderer': load succeeded.
Plugin 'OpenMesh': loading...
Plugin 'OpenMesh': load succeeded.
Plugin 'Qhull': loading...
Plugin 'Qhull': load succeeded.
Plugin 'ROS2Interface': loading...
Plugin 'ROS2Interface': warning: replaced variable 'simROS2'
Plugin 'ROS2Interface': load succeeded.
Plugin 'RRS1': loading...
Plugin 'RRS1': load succeeded.
Plugin 'ReflexxesTypeII': loading...
Plugin 'ReflexxesTypeII': load succeeded.
Plugin 'RemoteApi': loading...
Starting a remote API server on port 19997
Plugin 'RemoteApi': load succeeded.
Plugin 'SDF': loading...
Plugin 'SDF': warning: replaced variable 'simSDF'
Plugin 'SDF': load succeeded.
Plugin 'SurfaceReconstruction': loading...
Plugin 'SurfaceReconstruction': warning: replaced variable 'simSurfRec'
Plugin 'SurfaceReconstruction': load succeeded.
Plugin 'Urdf': loading...
Plugin 'Urdf': load succeeded.
Plugin 'Vision': loading...
Plugin 'Vision': load succeeded.
Using the 'Geometric' plugin.
START SIMPLE
START SIMPLE
START SIMPLE
terminate called after throwing an instance of 'boost::exception_detail::clone_impl<boost::exception_detail::error_info_injector<boost::io::bad_format_string> >'
  what():  boost::bad_format_string: format-string is ill-formed
/home/filipe/.coppelia_sim/coppeliaSim.sh: line 33:  4130 Aborted                 (core dumped) "$dirname/$appname" "${PARAMETERS[@]}"
Here is the link for my model: https://drive.google.com/file/d/19Gg914 ... sp=sharing

Thank you, in advance.
Regards.

lyz
Posts: 30
Joined: 07 Mar 2019, 07:34

Re: problem about new version coppeliaSim

Post by lyz » 09 Jan 2020, 08:35

Hi,
Yes, I have the same problem updating to CoppeliaSim. Because the new software delete the Vision sensor filters function. So I imported the model excluding the vision sensor into the software, it has no problems. Meanwhile I refer to bubbleRob.ttt to add vision sensor filter parts.

Code: Select all

function sysCall_vision(inData)
    simVision.sensorImgToWorkImg(inData.handle)
    simVision.edgeDetectionOnWorkImg(inData.handle,0.2)
    simVision.workImgToSensorImg(inData.handle)
end
If it doesn't work, you can look at the CoppeliaSim changelog to find a solution.
I hope that will help you.


In addition to this, as for the vision sensor, I found a problem that your depth/ rgb camera coordinates system were rotated around the z axis, so that the point cloud data came out was opposite to each other. The object seen by the camera moved to the left, while the image you saw in the ros moved to the right, which was a mirror. So there should be some problems in the actual use.

coppelia
Site Admin
Posts: 7527
Joined: 14 Dec 2012, 00:25

Re: problem about new version coppeliaSim

Post by coppelia » 13 Jan 2020, 08:22

Hello,

thanks to all of you. There was indeed a bug for the non-Windows version, and vision sensor filters. This and other bugs have been corrected. Make sure to download the updated version, V4.0.0.rev3

Cheers

Post Reply