Plugin loading failures

Typically: "How do I... ", "How can I... " questions
Post Reply
adubswils
Posts: 2
Joined: 21 May 2013, 09:04

Plugin loading failures

Post by adubswils » 21 May 2013, 18:23

Hello,

I am having trouble with a plugin that I have developed. v-rep indicates that it has failed to load the plugin and directs me to check whether the plugin can find all of its linked libraries. The plugin compiles correctly (it finds the v-rep header files), and ldd shows that all links are known. I am compiling on Fedora 18 using gcc 4.7.2.

Are there other failure modes for the plugin loader? For instance, is my version of gcc incompatible with the current v-rep binaries? If so, what version of gcc was v-rep compiled with? Are there other potential failure points I should be aware of?

coppelia
Site Admin
Posts: 7260
Joined: 14 Dec 2012, 00:25

Re: Plugin loading failures

Post by coppelia » 21 May 2013, 19:44

Hello,

Can you try:

export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:.
ldd libYourLibrary.so

What happens when you launch vrep.sh is that additional locations where to search for libraries are added. This might mix-up something..

Cheers

adubswils
Posts: 2
Joined: 21 May 2013, 09:04

Re: Plugin loading failures

Post by adubswils » 21 May 2013, 20:28

Hello,

I resolved the problem.

Currently, the vrep.sh script blows away the existing LD_LIBRARY_PATH. To overcome this problem I changed the vrep.sh script to append the library paths to the existing LD_LIBRARY_PATH. After this change the plugin was loaded correctly.

Thank you for the quick feedback.

Post Reply