Error installing in Ubuntu

Typically: "How do I... ", "How can I... " questions
Post Reply
parriaza
Posts: 6
Joined: 25 Mar 2013, 05:46

Error installing in Ubuntu

Post by parriaza » 17 Jun 2013, 19:55

I recently tried to install the educational version of vrep on my Linux machine runnning Ubuntu 12.04. I am completely new to Linux so that may be why I am having difficulty with this, but after I unzipped the folder for vrep I took a look at the readme and ran the program like it said using "./vrep.sh" in the terminal.

The logo proceeds to appear on my screen and then goes away followed by this error message:
Add-on script 'vrepAddOnScript-addOnScriptDemo.lua' was loaded.
Xlib: extension "GLX" missing on display ":0".
Xlib: extension "GLX" missing on display ":0".
Xlib: extension "GLX" missing on display ":0".
Xlib: extension "GLX" missing on display ":0".
QGLContext::makeCurrent(): Cannot make invalid context current.
terminate called after throwing an instance of 'std::logic_error'
what(): basic_string::_S_construct null not valid
Aborted (core dumped)

I tried using "ldd libv_rep.so" to see what libraries were missing and noticed that it could not find libqscintilla2.so.8, although it could clearly see the library in the vrep directory...so I'm not sure what that's about.

What can I do? Any help would be appreciated.

coppelia
Site Admin
Posts: 7079
Joined: 14 Dec 2012, 00:25

Re: Error installing in Ubuntu

Post by coppelia » 17 Jun 2013, 20:37

Hello,

This is very probably linked to your graphic card, since V-REP runs fine on a fresh Ubuntu 12.04 install.

Maybe this link, or that link can help.

Finally, if your problem is linked to an NVidia card, this post might help.

Cheers

parriaza
Posts: 6
Joined: 25 Mar 2013, 05:46

Re: Error installing in Ubuntu

Post by parriaza » 17 Jun 2013, 22:05

I figured out a solution to the problem (I think)...

I just needed to install Bumblebee and reboot. VREP seems to be working fine now.

Thanks for the help.

ostano
Posts: 2
Joined: 08 Aug 2013, 09:18

Re: Error installing in Ubuntu

Post by ostano » 08 Aug 2013, 10:14

Hello,

I have the same problem while trying to run ./vrep.sh in terminal.

But I think my case is a little different from your case, because the graphics card I have in my laptop is:
Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (primary) (rev0c)
So, could Bumblebee solve my problem?(So far I know Bumblebee is for Nvidia Optimus Laptop)

I would give it a try once I can use the "sudo" command in terminal (password is required)
But I would like to hear some suggestions while waiting.

Looking forward to any replies.

Regards

Post Reply