V-REP crash (running several instances of V-REP with several remote API clients)

Report crashes, strange behaviour, or apparent bugs
fferri
Posts: 440
Joined: 09 Sep 2013, 19:28

Re: V-REP crash (running several instances of V-REP with several remote API clients)

Post by fferri » 25 Jun 2019, 17:39

Uli_v wrote:
25 Jun 2019, 16:56
How do I compile the plugin in debug mode?
If it is based on CMake, then pass option -DCMAKE_BUILD_TYPE=Debug to cmake.

If it is based on QMake, then pass CONFIG+=debug to qmake.

Uli_v
Posts: 35
Joined: 14 Dec 2018, 18:07

Re: V-REP crash (running several instances of V-REP with several remote API clients)

Post by Uli_v » 26 Jun 2019, 16:17

I git cloned: https://github.com/CoppeliaRobotics/v_repExtRemoteApi

I then I tried:

Code: Select all

cmake -DCMAKE_BUILD_TYPE=Debug
But there is no CMakeLists.txt.

What are all the steps necessary to build/cmake the RemoteApi plugin? Thanks.

fferri
Posts: 440
Joined: 09 Sep 2013, 19:28

Re: V-REP crash (running several instances of V-REP with several remote API clients)

Post by fferri » 26 Jun 2019, 18:47

Uli_v wrote:
26 Jun 2019, 16:17
I git cloned: https://github.com/CoppeliaRobotics/v_repExtRemoteApi

I then I tried:

Code: Select all

cmake -DCMAKE_BUILD_TYPE=Debug
But there is no CMakeLists.txt.

What are all the steps necessary to build/cmake the RemoteApi plugin? Thanks.
That's a QMake based plugin

Uli_v
Posts: 35
Joined: 14 Dec 2018, 18:07

Re: V-REP crash (running several instances of V-REP with several remote API clients)

Post by Uli_v » 26 Jun 2019, 19:09

So what are the steps to make this via qmake?

Post Reply