issue with turtlebot urdf import

Typically: "How do I... ", "How can I... " questions
Post Reply
nng
Posts: 2
Joined: 31 Oct 2014, 11:51
Contact:

issue with turtlebot urdf import

Post by nng » 31 Oct 2014, 12:30

Hi there,

I want to import the urdf model of turtlebot into v-rep.
The conversion from xacro to urdf works and no error were reported by the check_urdf command, however, a few errors occur during import. Specifically with the sensors, see excerpt below.
There are 6 sensors.
ERROR: sensor will not be created: the URDF specification is supported, but this is a Gazebo tag which is not documented as it seems.
...
You can generate the urdf model by instaling the turtlebot on your workstation as indicated in point "4.2 Workspaces" on the link below.
http://wiki.ros.org/turtlebot/Tutorials ... stallation
Link or copy the folder "kobuki_description" into the folder "turtlebot_description"
then you can generate the urdf model by executing the command below, make sure the generated urdf model is stored in the folder
"turtlebot_description/robots/"
being in the folder turtlebot_description/robots/ execute
rosrun xacro xacro.py kobuki_hexagons_asus_xtion_pro.urdf.xacro -o kobuki_hexagons_asus_xtion_pro.urdf
Then check the correctness of the model
check_urdf kobuki_hexagons_asus_xtion_pro.urdf
import the model in v-rep

Using:
V-REP_PRO_EDU_V3_1_3_rev2b_64_Linux
Ubuntu 14.04 64bit
ROS Indigo

Thank you in advance.

coppelia
Site Admin
Posts: 7150
Joined: 14 Dec 2012, 00:25

Re: issue with turtlebot urdf import

Post by coppelia » 01 Nov 2014, 01:38

Hello,

the URDF that is supported in V-REP is the official URDF, which doesn't specify certain tags used in other simulators.

Cheers

Post Reply