After importing a mesh(.obj), it is transparent

Typically: "How do I... ", "How can I... " questions
Post Reply
Zhuang
Posts: 25
Joined: 02 Aug 2017, 14:43

After importing a mesh(.obj), it is transparent

Post by Zhuang » 17 Apr 2018, 15:13

Hi, everybody
I try to import a shape (.obj) into vrep(3.5.4) . but it is transparent in vrep even if i change layers. the mesh(with text) can be displayed in meshlab.
how to deal with the problem?

coppelia
Site Admin
Posts: 7330
Joined: 14 Dec 2012, 00:25

Re: After importing a mesh(.obj), it is transparent

Post by coppelia » 17 Apr 2018, 17:23

Hello,

when you say transparent, you mean invisible?

Then, it can be that you have one of following situaions:
  • the mesh is extremely large and you cannot see it
  • the mesh is extremely small and you cannot see it
  • the mesh is somehow corrupt. But this situation normally doesn't happen.
You can select it, and scale it up/down to see if it suddenly appears. You can inspect the size of a shape's bounding box in this dialog.

Cheers

Zhuang
Posts: 25
Joined: 02 Aug 2017, 14:43

Re: After importing a mesh(.obj), it is transparent

Post by Zhuang » 18 Apr 2018, 06:28

coppelia wrote:
17 Apr 2018, 17:23
Hello,

when you say transparent, you mean invisible?

Then, it can be that you have one of following situaions:
  • the mesh is extremely large and you cannot see it
  • the mesh is extremely small and you cannot see it
  • the mesh is somehow corrupt. But this situation normally doesn't happen.
You can select it, and scale it up/down to see if it suddenly appears. You can inspect the size of a shape's bounding box in this dialog.

Cheers
Hello, coppelia
thank u for your answer.
when I click it the model, i can see its bounding box. but it is not invisible like air. and I think its size is fitting in the sense.
there is the model file (.obj):https://www.dropbox.com/s/w6w8ar7iza043 ... ar.gz?dl=0

cheers

coppelia
Site Admin
Posts: 7330
Joined: 14 Dec 2012, 00:25

Re: After importing a mesh(.obj), it is transparent

Post by coppelia » 19 Apr 2018, 08:16

Your imported mesh has a color opacity of zero. Uncheck the Opacity box simply, in the color dialog for the shape.
Don't know how the import operation picked that up from the files

Cheers

Post Reply