Search found 6 matches

by Rufio2790
18 Jun 2021, 07:45
Forum: Bug reports
Topic: [BUILD ISSUE] SimClientApplication
Replies: 1
Views: 18745

[BUILD ISSUE] SimClientApplication

Dear all, I'm trying to compile coppeliasim to be used on Debian 10. I've already been able to compile the coppeliaSim library following the instruction provided (however we use Qt5.15 instead of 5.12 used in version 4.2.0, but I understand that it does not matter if we re-compile everything). Howev...
by Rufio2790
01 Jun 2021, 13:43
Forum: Bug reports
Topic: [Headless Mode] Cannot run plug in
Replies: 5
Views: 20316

Re: [Headless Mode] Cannot run plug in

Dear all, the addOn consist in loading and running a function in a custom plug in. Something like this should be enough to test: function sysCall_info() return {autoStart=false} end function sysCall_init() print("I'm executing the addon") sim.addLog(sim.verbosity_msgs,"CHECK EXECUTION") -- here is w...
by Rufio2790
01 Jun 2021, 11:30
Forum: Bug reports
Topic: [Headless Mode] Cannot run plug in
Replies: 5
Views: 20316

Re: [Headless Mode] Cannot run plug in

Hello, Thanks for the answer. We are seeing this problem with CoppeliaSim4.2.0, on both Windows and MacOS platforms. Actually, we already tried prints in the sys_init callback and we could no see any message in the console. Comparing the console output between the UI mode and Headless mode, we see t...
by Rufio2790
01 Jun 2021, 07:21
Forum: Bug reports
Topic: [Headless Mode] Cannot run plug in
Replies: 5
Views: 20316

[Headless Mode] Cannot run plug in

Dear all, We are trying to run a simulation in headless mode through a plugin + addOn we developed, but we do not find the expected output. This is the command we are running from the console: ./coppeliaSim.exe -h -s5000 -q ./roboticSystem.ttt -vdebug -bsimAddOnReachabilitySimulation.lua The plugin ...
by Rufio2790
13 May 2021, 11:22
Forum: General questions
Topic: remoteApi plugin problem
Replies: 9
Views: 4578

Re: remoteApi plugin problem

As you suggested, I moved the remoteApiConnection.txt from Resources to MacOs, and it worked! It seems the trick solves the problem without overriding the remoteApi.dylib with the one that can be found on github. Basically, at least on MacOS, copying the remoteApiConnection.txt to the MacOs folder w...
by Rufio2790
11 May 2021, 12:27
Forum: General questions
Topic: remoteApi plugin problem
Replies: 9
Views: 4578

Re: remoteApi plugin problem

Dear all,

I've tried today the remoteApiBindings lib for MacOs (it seems they have been updated 5 days ago on github), but the problem persist with the version 4.2 (overriding the old one in the programming folder).
Version 4.1 works fine.

Cheers