Search found 33 matches

by sumi_boss
02 Mar 2021, 16:30
Forum: General questions
Topic: sim.rmlMoveToPosition problem
Replies: 11
Views: 604

Re: sim.rmlMoveToPosition problem

Hello I made it work by changing the concept a little bit. I have a question with regard to these functions. I am using them to incrementally move the robot and I have an algorithm for impedance control. I noticed that the success of my algorithm greatly depends on parameters like the desired and ma...
by sumi_boss
02 Mar 2021, 13:17
Forum: General questions
Topic: How to impose force on the end-effect (TCP)?
Replies: 2
Views: 171

Re: How to impose force on the end-effect (TCP)?

Hello

I'm working on a similar task, so I thought I'd reply here too. The tutorial you posted is for force-controlled manipulators, but it focuses on joint force control. Is there anywhere we could find something out about end effector (TCP) force control in Coppelia?

Cheers
by sumi_boss
19 Feb 2021, 15:37
Forum: General questions
Topic: sim.rmlMoveToPosition problem
Replies: 11
Views: 604

Re: sim.rmlMoveToPosition problem

I did that, and it shows just 2 yellow points of contact. They appear for a moment and then disappear. But, they did that when the assemblage was successful too. I'm not sure if that's the reason that the objects get stuck. I also don't understand how the problem could be in the code? The main diffe...
by sumi_boss
19 Feb 2021, 10:59
Forum: General questions
Topic: sim.rmlMoveToPosition problem
Replies: 11
Views: 604

Re: sim.rmlMoveToPosition problem

What do you mean by visualizing contact points? I paused the simulation after the top part gets stuck, zoom the objects, and inspect them visually and I cant see a collision anywhere. As I said, the objects aren't even touching. I tried with different physics engines and the same thing happened. I a...
by sumi_boss
17 Feb 2021, 12:30
Forum: General questions
Topic: sim.rmlMoveToPosition problem
Replies: 11
Views: 604

Re: sim.rmlMoveToPosition problem

Hi, Yes, that was indeed the problem, and after changing the targetPosVelAccel values, it now works much better. My task is the assemblage of two pieces (each held by a gripper) under a certain force. I place the objects close to each other in a pre-assembly position and then try to assemble them in...
by sumi_boss
09 Feb 2021, 17:00
Forum: General questions
Topic: sim.rmlMoveToPosition problem
Replies: 11
Views: 604

Re: sim.rmlMoveToPosition problem

Hi, I tried doing that, and it works fine for the first iteration of the loop. In the second iteration, the sim.rmlStep function returns an error code -100: RML_ERROR_INVALID_INPUT_VALUES. Since the input values are just the object handle and the time step, I assume something is wrong with the time ...
by sumi_boss
05 Feb 2021, 15:52
Forum: General questions
Topic: sim.rmlMoveToPosition problem
Replies: 11
Views: 604

Re: sim.rmlMoveToPosition problem

Thanks for the info, I looked at the examples you mentioned. In the examples, you used sim.rmlPos in a threaded script. You first set the object with that function, and then you call the sim.rmlStep function in a while loop. However, this is just for 'stepping'. The original trajectory object remain...
by sumi_boss
01 Feb 2021, 10:35
Forum: General questions
Topic: sim.rmlMoveToPosition problem
Replies: 11
Views: 604

sim.rmlMoveToPosition problem

Hello, I have a problem with sim.rmlMoveToPosition function. I planned a trajectory for my robot and I want to use this function in a for loop for each small part of this trajectory. The first time I call the function the robot does move, but when I call the function repeatedly (in the loop), for sm...
by sumi_boss
22 Jan 2021, 13:48
Forum: General questions
Topic: Robot IK mode problem
Replies: 6
Views: 278

Re: Robot IK mode problem

Here is the github link, the file is dualArmUR5ver2

https://github.com/sumiboss95/coppelia
by sumi_boss
22 Jan 2021, 12:46
Forum: General questions
Topic: Robot IK mode problem
Replies: 6
Views: 278

Re: Robot IK mode problem

Hello,

The is the Google drive link to the folder with the scene.
https://drive.google.com/drive/folders/ ... sp=sharing

The robot in question is the 'UR5#1'

Cheers