RemoteAPI simxReadVisionSensor crashing on MacOSX

Report crashes, strange behaviour, or apparent bugs
Post Reply
bnewman
Posts: 7
Joined: 05 Jul 2013, 19:51

RemoteAPI simxReadVisionSensor crashing on MacOSX

Post by bnewman »

I am doing simulation for the KheperaIII robot remotely with Java. When attempting to use the Vision Sensors for the bottom 2 color sensors using simxReadVisionSensor, for the first read I have attempted to use simx_opmode_streaming as the API suggest but this crashed VREP on the MacOSX Mountain Lion. I was able to narrow it down to this by changing the parameter to simx_opmode_oneshot, but that will not allow for the sensors to update. I have also tried to use simx_opmode_buffer, but this also crashed VREP.

I went back and forth for sometime trying to get this to work on OSX, but it never seemed to work. I think attempted to use the same Java code on Windows with Streaming for the first and buffer after and VREP was able to run well. On OSX, VREP will run if I do the first read as simx_opmode_oneshot and after simx_opmode_buffer, but the values do not change.

I am using V-REP PRO EDU Version 3.0.3 64bit (serialization version 16), MacBook Pro i7.

Billy

coppelia
Site Admin
Posts: 8047
Joined: 14 Dec 2012, 00:25

Re: RemoteAPI simxReadVisionSensor crashing on MacOSX

Post by coppelia »

Hello Billy,

Thanks for mentionning this. We will have a look at this, and be back within a few days. Sorry about the inconvenience.

Cheers

coppelia
Site Admin
Posts: 8047
Joined: 14 Dec 2012, 00:25

Re: RemoteAPI simxReadVisionSensor crashing on MacOSX

Post by coppelia »

Hello Billy,

Thanks for reporting this bug. It was corrected (together with another bug on the Java client side).

Here the fixed libraries:
Cheers

coppelia
Site Admin
Posts: 8047
Joined: 14 Dec 2012, 00:25

Re: RemoteAPI simxReadVisionSensor crashing on MacOSX

Post by coppelia »

Forgot to mention: on Mac, just copy libv_repExtRemoteApi.dylib into the vrep.app/Contents/MacOS/ folder (inside the vrep.app package)

Post Reply