vrep folder missing

Report crashes, strange behaviour, or apparent bugs
Post Reply
vra
Posts: 6
Joined: 12 Dec 2019, 11:12

vrep folder missing

Post by vra » 17 Dec 2019, 12:43

Hi all, how are you?. First I whish to congratulate the team of coppelia for such an excellent program to simulate robots and their behaviors.

Now I need to ask for something, I've downloaded the Coppelia versions for windows and ubunti 64 bits, the windows version works flawleslly but the ubuntu version which I'm trying to install in debian 9 apparently doesn't have the folder vrep after uncompressed from the .tar.xz file and therefore I can't install it, what can I do about it?.

Thanks in advance for the help.

coppelia
Site Admin
Posts: 7691
Joined: 14 Dec 2012, 00:25

Re: vrep folder missing

Post by coppelia » 18 Dec 2019, 22:52

Hello,

it doesn't have any vrep folder anymore, since the software changed to CoppeliaSim. On Ubuntu there is no installation procedure. Simply decompress it, and from the terminal, in that folder, run coppeliaSim.sh

Cheers

vra
Posts: 6
Joined: 12 Dec 2019, 11:12

Re: vrep folder missing

Post by vra » 19 Dec 2019, 14:14

Hi, I taught that and tried to run that file before asking, then I had the following responses:

running it as a normal user:

Code: Select all

root@d-valer:/media/valery/Users/valery/Downloads/CoppeliaSim_Edu_V4_0_0_Ubuntu18_04# sh coppeliaSim.sh
coppeliaSim.sh: 15: coppeliaSim.sh: Syntax error: "(" unexpected
running it as a superuser:

Code: Select all

root@d-valer:/media/valery/Users/valery/Downloads/CoppeliaSim_Edu_V4_0_0_Ubuntu18_04# ./coppeliaSim.sh
Loading the CoppeliaSim library...
CoppeliaSim client app error: could not find or correctly load the CoppeliaSim library
and I couldn't run it.

Does it has a special requirement and do I need to place it in an specific folder?.

fferri
Posts: 532
Joined: 09 Sep 2013, 19:28

Re: vrep folder missing

Post by fferri » 19 Dec 2019, 14:24

You are running it as superuser in both cases. the only difference is that in the first case you use the sh shell (wrong).

Simply run ./coppeliaSim.sh as normal user.

vra
Posts: 6
Joined: 12 Dec 2019, 11:12

Re: vrep folder missing

Post by vra » 19 Dec 2019, 15:59

Thanks, I'll try

vra
Posts: 6
Joined: 12 Dec 2019, 11:12

Re: vrep folder missing

Post by vra » 19 Dec 2019, 22:32

I've tried what you said as normal user and it keeps me saying that it couldn't find the coppelia libraries, look at the code below:

Code: Select all

/media/valery/Users/valery/Downloads/CoppeliaSim_Edu_V4_0_0_Ubuntu18_04$ ./coppeliaSim.sh
Loading the CoppeliaSim library...
CoppeliaSim client app error: could not find or correctly load the CoppeliaSim library
in fact, it says the same as normal user and as superuser.

What can I do?

fferri
Posts: 532
Joined: 09 Sep 2013, 19:28

Re: vrep folder missing

Post by fferri » 20 Dec 2019, 13:22

vra wrote:
19 Dec 2019, 22:32

Code: Select all

/media/valery/Users/valery/Downloads/CoppeliaSim_Edu_V4_0_0_Ubuntu18_04$ ./coppeliaSim.sh
Loading the CoppeliaSim library...
CoppeliaSim client app error: could not find or correctly load the CoppeliaSim library
You should check that:
  • libcoppeliaSim.so file is present and readable (maybe post the output of ls -l run in the CoppeliaSim_Edu_V4_0_0_Ubuntu18_0 directory)
  • all the dependencies are present (i.e. none is reported as not found). you can check that with ldd libcoppeliaSim.so

vra
Posts: 6
Joined: 12 Dec 2019, 11:12

Re: vrep folder missing

Post by vra » 20 Dec 2019, 22:23

Well, libcoppeliaSim.so is present but my OS, debian 9 lacks GLIBC 2.27 and Qt5.12, I'm trying to learn how to install them, see the following answer from terminal.

Code: Select all

./libcoppeliaSim.so: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.27' not found (required by ./libcoppeliaSim.so)
./libcoppeliaSim.so: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: version `Qt_5.12' not found (required by ./libcoppeliaSim.so)
	linux-vdso.so.1 (0x00007ffda5d3d000)
	liblua5.1.so => /usr/lib/x86_64-linux-gnu/liblua5.1.so (0x00007f4669622000)
	libQt5OpenGL.so.5 => /usr/lib/x86_64-linux-gnu/libQt5OpenGL.so.5 (0x00007f466a9cd000)
	libQt5Widgets.so.5 => /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5 (0x00007f4668fbf000)
	libQt5Gui.so.5 => /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5 (0x00007f4668a86000)
	libQt5SerialPort.so.5 => /usr/lib/x86_64-linux-gnu/libQt5SerialPort.so.5 (0x00007f466a9b4000)
	libQt5Core.so.5 => /usr/lib/x86_64-linux-gnu/libQt5Core.so.5 (0x00007f46685b6000)
	libGL.so.1 => /usr/lib/x86_64-linux-gnu/libGL.so.1 (0x00007f4668344000)
	libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007f4668127000)
	libstdc++.so.6 => /usr/lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007f4667da5000)
	libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007f4667aa1000)
	libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007f466788a000)
	libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f46674eb000)
	libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007f46672e7000)
	libharfbuzz.so.0 => /usr/lib/x86_64-linux-gnu/libharfbuzz.so.0 (0x00007f4667052000)
	libz.so.1 => /lib/x86_64-linux-gnu/libz.so.1 (0x00007f4666e38000)
	libpng16.so.16 => /usr/lib/x86_64-linux-gnu/libpng16.so.16 (0x00007f4666c05000)
	libudev.so.1 => /lib/x86_64-linux-gnu/libudev.so.1 (0x00007f466a98f000)
	libicui18n.so.57 => /usr/lib/x86_64-linux-gnu/libicui18n.so.57 (0x00007f466678a000)
	libicuuc.so.57 => /usr/lib/x86_64-linux-gnu/libicuuc.so.57 (0x00007f46663e2000)
	libpcre16.so.3 => /usr/lib/x86_64-linux-gnu/libpcre16.so.3 (0x00007f4666179000)
	libdouble-conversion.so.1 => /usr/lib/x86_64-linux-gnu/libdouble-conversion.so.1 (0x00007f4665f68000)
	libglib-2.0.so.0 => /lib/x86_64-linux-gnu/libglib-2.0.so.0 (0x00007f4665c54000)
	librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007f4665a4c000)
	/lib64/ld-linux-x86-64.so.2 (0x00007f466a82d000)
	libexpat.so.1 => /lib/x86_64-linux-gnu/libexpat.so.1 (0x00007f4665822000)
	libxcb-dri3.so.0 => /usr/lib/x86_64-linux-gnu/libxcb-dri3.so.0 (0x00007f466561f000)
	libxcb-present.so.0 => /usr/lib/x86_64-linux-gnu/libxcb-present.so.0 (0x00007f466541c000)
	libxcb-sync.so.1 => /usr/lib/x86_64-linux-gnu/libxcb-sync.so.1 (0x00007f4665215000)
	libxshmfence.so.1 => /usr/lib/x86_64-linux-gnu/libxshmfence.so.1 (0x00007f4665013000)
	libglapi.so.0 => /usr/lib/x86_64-linux-gnu/libglapi.so.0 (0x00007f4664de4000)
	libXext.so.6 => /usr/lib/x86_64-linux-gnu/libXext.so.6 (0x00007f4664bd2000)
	libXdamage.so.1 => /usr/lib/x86_64-linux-gnu/libXdamage.so.1 (0x00007f46649cf000)
	libXfixes.so.3 => /usr/lib/x86_64-linux-gnu/libXfixes.so.3 (0x00007f46647c9000)
	libX11-xcb.so.1 => /usr/lib/x86_64-linux-gnu/libX11-xcb.so.1 (0x00007f46645c7000)
	libX11.so.6 => /usr/lib/x86_64-linux-gnu/libX11.so.6 (0x00007f4664287000)
	libxcb.so.1 => /usr/lib/x86_64-linux-gnu/libxcb.so.1 (0x00007f466405f000)
	libxcb-glx.so.0 => /usr/lib/x86_64-linux-gnu/libxcb-glx.so.0 (0x00007f4663e44000)
	libxcb-dri2.so.0 => /usr/lib/x86_64-linux-gnu/libxcb-dri2.so.0 (0x00007f4663c3f000)
	libXxf86vm.so.1 => /usr/lib/x86_64-linux-gnu/libXxf86vm.so.1 (0x00007f4663a39000)
	libdrm.so.2 => /usr/lib/x86_64-linux-gnu/libdrm.so.2 (0x00007f4663829000)
	libfreetype.so.6 => /usr/lib/x86_64-linux-gnu/libfreetype.so.6 (0x00007f466357a000)
	libgraphite2.so.3 => /usr/lib/x86_64-linux-gnu/libgraphite2.so.3 (0x00007f466334d000)
	libicudata.so.57 => /usr/lib/x86_64-linux-gnu/libicudata.so.57 (0x00007f46618d0000)
	libpcre.so.3 => /lib/x86_64-linux-gnu/libpcre.so.3 (0x00007f466165d000)
	libXau.so.6 => /usr/lib/x86_64-linux-gnu/libXau.so.6 (0x00007f4661459000)
	libXdmcp.so.6 => /usr/lib/x86_64-linux-gnu/libXdmcp.so.6 (0x00007f4661253000)
Anyway, if you can explain me how and where to get it i'll be grateful.

fferri
Posts: 532
Joined: 09 Sep 2013, 19:28

Re: vrep folder missing

Post by fferri » 20 Dec 2019, 22:28

Ubuntu is the only supported Linux distribution.

Try rebuilding the library yourself. See compiling CoppeliaSim and related items.

vra
Posts: 6
Joined: 12 Dec 2019, 11:12

Re: vrep folder missing

Post by vra » 22 Dec 2019, 20:26

Hi, I did a search around there and apparently the qt and GLIBC available for Debian 9 are inferior to the ones needed by coppelia and may be it's possible to install the needed ones by adding some repos but I managed to use coppeliaSim in a fastest way.

What I did was to install the windows version with playonlinux and using wine 64 bits, now it runs without problems until now.

Post Reply