Proximity Sensors Loosing Settings when Copy Pasting

Report crashes, strange behaviour, or apparent bugs
Post Reply
lightgear
Posts: 4
Joined: 07 Oct 2020, 22:35

Proximity Sensors Loosing Settings when Copy Pasting

Post by lightgear »

Morning, I am working on a project where multiple models have a proximity sensor that can only detect one simple cuboid in the scene. I tested my scene with one model and it correctly followed the cuboid however when I copy and pasted the same model the second model did not follow the cuboid.

After looking through my code to no avail I checked the proximity sensor settings of the second model to find that the 'Enity able to detect' had been reset to all models in the scene rather than just the cuboid.

Wondering if this is deliberate in the program or if their is a way to disable this.

Cheers

lightgear
Posts: 4
Joined: 07 Oct 2020, 22:35

Re: Proximity Sensors Loosing Settings when Copy Pasting

Post by lightgear »

I have also found when I transfer DNA of the original Model it resets the Proximity sensor Entity to Detect for all other models.

coppelia
Site Admin
Posts: 8371
Joined: 14 Dec 2012, 00:25

Re: Proximity Sensors Loosing Settings when Copy Pasting

Post by coppelia »

Hello,

this is normal if you do not copy-paste the cuboid in the same operation. What happens is following:

sensor --> cuboid

if you copy-paste above two objects at the same time you will get:

sensor2 --> cuboid2

If you only copy-paste the sensor, you will get:

sensor -->

This is an important mechanism, for correctly scaling of the simulation content.

The transfer DNA functionality is there even a bit more tricky, but currently blindly duplicates and renames models. That functionality will however be completely reworked in close future for much better control on what properties are transferred.

Cheers

Post Reply