Simulator won't run on Ubuntu 20.04 64-bit - Undefined symbol

Report crashes, strange behaviour, or apparent bugs
Post Reply
TeoProt
Posts: 3
Joined: 19 Nov 2020, 13:32

Simulator won't run on Ubuntu 20.04 64-bit - Undefined symbol

Post by TeoProt »

I am trying to run Coppelia Simulator on Ubuntu 20.04 64-bit. I am running the script and I keep getting the following error:

./coppeliaSim: symbol lookup error: ./coppeliaSim: undefined symbol: _ZdlPvm, version Qt_5

I did some online search but I was unable to find a proper solution. The versions of Qt installed are:

qtchooser -list-versions
4
5
default
qt4-x86_64-linux-gnu
qt4
qt5-x86_64-linux-gnu
qt5


I could really use some help in order to make the simulator run properly.

coppelia
Site Admin
Posts: 8371
Joined: 14 Dec 2012, 00:25

Re: Simulator won't run on Ubuntu 20.04 64-bit - Undefined symbol

Post by coppelia »

Hello,

how exactly are you trying to start CoppeliaSim?
What is the complete error output?

Cheers

TeoProt
Posts: 3
Joined: 19 Nov 2020, 13:32

Re: Simulator won't run on Ubuntu 20.04 64-bit - Undefined symbol

Post by TeoProt »

coppelia wrote:
24 Nov 2020, 15:21
Hello,

how exactly are you trying to start CoppeliaSim?
What is the complete error output?

Cheers
I navigate to the folder containing all the files of the simulator and running the launch script like:

./coppeliaSim

And the output is the following:

./coppeliaSim: symbol lookup error: ./coppeliaSim: undefined symbol: _ZdlPvm, version Qt_5

TeoProt
Posts: 3
Joined: 19 Nov 2020, 13:32

Re: Simulator won't run on Ubuntu 20.04 64-bit - Undefined symbol

Post by TeoProt »

I have to confess that the problem was that I was running the command:

./coppeliaSim

instead of the appropriate command:

./coppeliaSim.sh

Now, it is solved.

ohnowhathaveidone
Posts: 14
Joined: 31 Mar 2020, 13:02

Re: Simulator won't run on Ubuntu 20.04 64-bit - Undefined symbol

Post by ohnowhathaveidone »

As a side note: should you want to run the coppeliaSim binary directly (e. g. for headless simulations or if you want gdb/valgrind it), you can first run

Code: Select all

source coppeliaSim.sh
to set the environment variables correctly in your shell session. After this, you can start the binary directly (in that one shell session). This will, however, likely break the environment for other binaries in the session.

(#worksOnMyMachine though... :) )

fferri
Posts: 714
Joined: 09 Sep 2013, 19:28

Re: Simulator won't run on Ubuntu 20.04 64-bit - Undefined symbol

Post by fferri »

Better to use:

Code: Select all

LD_LIBRARY_PATH=$COPPELIASIM_ROOT_DIR:$LD_LIBRARY_PATH gdb coppeliaSim
it won't break the current environment for other programs.

cheers

Post Reply