Errors with B0 and ZeroMQ add-ons and remote api clients.

Typically: "How do I... ", "How can I... " questions
ask4jubad
Posts: 11
Joined: 21 Sep 2021, 07:46

Errors with B0 and ZeroMQ add-ons and remote api clients.

Post by ask4jubad »

Hello Coppelia,

I have been having issues with working with the remote apis, ZeroMQ and B0remote api. For the latter, it used to work some weeks ago, but I can't say for sure what changed during the time it started giving errors. For ZeroMQ, it just doesn't work.

I get the following error on my zeromq client side: with code from coppeliarobotics here
sim = client.getobject('sim')
AttributeError: 'RemoteAPIClient' object has no attribute 'getobject'
as well as this when I run

Code: Select all

cmake ..
in zmqRemoteApi/build folder:
-- CoppeliaSim: LIBPLUGIN_DIR: /home/jubril/Downloads/CoppeliaSim/programming/libPlugin.
-- CoppeliaSim: COPPELIASIM_ROOT_DIR: /home/jubril/Downloads/CoppeliaSim.
-- Found CoppeliaSim installation at /home/jubril/Downloads/CoppeliaSim.
-- Checking CoppeliaSim header version...
-- CoppeliaSim headers version 4.2.0 rev6
CMake Error at /home/jubril/Downloads/CoppeliaSim/programming/libPlugin/cmake/FindCoppeliaSim.cmake:17 (message):
Found CoppeliaSim version 4.2.0.6 but 4.3.0.0 required.
Call Stack (most recent call first):
/home/jubril/Downloads/CoppeliaSim/programming/libPlugin/cmake/FindCoppeliaSim.cmake:136 (coppeliasim_find_error)
CMakeLists.txt:15 (find_package)

-- Configuring incomplete, errors occurred!
See also "/home/jubril/Downloads/CoppeliaSim/programming/zmqRemoteApi/build/CMakeFiles/CMakeOutput.log".
The other areas of concern are framed green in the snapshot here: error snapshot.

Not that I have cloned ZeroMQ remote into CoppeliaSim/programming, added the compatibility add-on to CoppeliaSim/ and cbor.lua and simZMQ.lua into CoppeliaSim/lua.

These are the System details:
Distributor ID: Ubuntu
Description: Ubuntu 21.04
Release: 21.04
Codename: hirsute

CoppeliaSim Edu, Version 4.2.0. (rev. 6) 64bit (serialization version 23) (Qt Version 5.12.5, GCC)

coppelia
Site Admin
Posts: 8974
Joined: 14 Dec 2012, 00:25

Re: Errors with B0 and ZeroMQ add-ons and remote api clients.

Post by coppelia »

Hello,

let's focus on the ZeroMQ-based remote API: please try by spelling client.getObject('sim') correctly (it is case-sensitive)

Then, from within the zmqRemoteApi cloned repository, you do not need to run cmake, simply navigate to zmqRemoteApi/clients/python/ and run:

Code: Select all

python ./simpleTest.py
(make sure CoppeliaSim is running and the zmq Remote Api add-on is running). Does it work?

Cheers

ask4jubad
Posts: 11
Joined: 21 Sep 2021, 07:46

Re: Errors with B0 and ZeroMQ add-ons and remote api clients.

Post by ask4jubad »

Thanks Coppelia,

The simpleTest.py starts running by printing the first line ("Program Started"), but like I mentioned in my previous message, the error dialogue is this in CoppeliaSim:
[ZMQ remote API server@addOnScript:error] zmqRemoteApi: the ZMQ plugin is not available
[ZMQ remote API@addOnScript:error] zmqRemoteApi: the ZMQ plugin is not available
I even added both the simAddOnZMQ remote API.lua and the simAddOnZMQ remote API server.lua in CoppeliaSim/, CoppeliaSim/lua and CoppeliaSim/programming/ to no avail.

So, I would say it doesn't work.

coppelia
Site Admin
Posts: 8974
Joined: 14 Dec 2012, 00:25

Re: Errors with B0 and ZeroMQ add-ons and remote api clients.

Post by coppelia »

Please check your terminal when launching CoppeliaSim. Any error messages there?

Cheers

ask4jubad
Posts: 11
Joined: 21 Sep 2021, 07:46

Re: Errors with B0 and ZeroMQ add-ons and remote api clients.

Post by ask4jubad »

Thanks for the response.

These are the messages on the terminal from the point where the first error surfaces:
[CoppeliaSim:error] plugin 'B0': load failed (could not load). The plugin probably couldn't load dependency libraries. For additional infos, modify the script 'libLoadErrorCheck.sh', run it and inspect the output.
[CoppeliaSim:loadinfo] plugin 'BWF': loading...
[CoppeliaSim:loadinfo] plugin 'BWF': load succeeded.
[CoppeliaSim:loadinfo] plugin 'BubbleRob': loading...
[CoppeliaSim:loadinfo] plugin 'BubbleRob': load succeeded.
[CoppeliaSim:loadinfo] plugin 'Bullet-2-78': loading...
[CoppeliaSim:loadinfo] plugin 'Bullet-2-78': load succeeded.
[CoppeliaSim:loadinfo] plugin 'Bullet-2-83': loading...
[CoppeliaSim:loadinfo] plugin 'Bullet-2-83': load succeeded.
[CoppeliaSim:loadinfo] plugin 'CodeEditor': loading...
[CoppeliaSim:loadinfo] plugin 'CodeEditor': load succeeded.
[CoppeliaSim:loadinfo] plugin 'ConvexDecompose': loading...
[CoppeliaSim:loadinfo] plugin 'ConvexDecompose': load succeeded.
[CoppeliaSim:loadinfo] plugin 'ExternalRenderer': loading...
[CoppeliaSim:loadinfo] plugin 'ExternalRenderer': load succeeded.
[CoppeliaSim:loadinfo] plugin 'GLTF': loading...
[CoppeliaSim:loadinfo] plugin 'GLTF': load succeeded.
[CoppeliaSim:loadinfo] plugin 'Geom': loading...
[CoppeliaSim:loadinfo] plugin 'Geom': load succeeded.
[CoppeliaSim:loadinfo] plugin 'ICP': loading...
[CoppeliaSim:loadinfo] plugin 'ICP': load succeeded.
[CoppeliaSim:loadinfo] plugin 'IK': loading...
[CoppeliaSim:loadinfo] plugin 'IK': load succeeded.
[CoppeliaSim:loadinfo] plugin 'IM': loading...
[CoppeliaSim:error] plugin 'IM': load failed (could not load). The plugin probably couldn't load dependency libraries. For additional infos, modify the script 'libLoadErrorCheck.sh', run it and inspect the output.
[CoppeliaSim:loadinfo] plugin 'K3': loading...
[CoppeliaSim:loadinfo] plugin 'K3': load succeeded.
[CoppeliaSim:loadinfo] plugin 'LuaCmd': loading...
[CoppeliaSim:loadinfo] plugin 'LuaCmd': load succeeded.
[CoppeliaSim:loadinfo] plugin 'LuaRemoteApiClient': loading...
[CoppeliaSim:loadinfo] plugin 'LuaRemoteApiClient': load succeeded.
[CoppeliaSim:loadinfo] plugin 'MTB': loading...
[CoppeliaSim:loadinfo] plugin 'MTB': load succeeded.
[CoppeliaSim:loadinfo] plugin 'Newton': loading...
[CoppeliaSim:loadinfo] plugin 'Newton': load succeeded.
[CoppeliaSim:loadinfo] plugin 'ODE': loading...
[CoppeliaSim:loadinfo] plugin 'ODE': load succeeded.
[CoppeliaSim:loadinfo] plugin 'OMPL': loading...
[CoppeliaSim:error] plugin 'OMPL': load failed (could not load). The plugin probably couldn't load dependency libraries. For additional infos, modify the script 'libLoadErrorCheck.sh', run it and inspect the output.
[CoppeliaSim:loadinfo] plugin 'OpenGL3Renderer': loading...
[CoppeliaSim:loadinfo] plugin 'OpenGL3Renderer': load succeeded.
[CoppeliaSim:loadinfo] plugin 'OpenMesh': loading...
[CoppeliaSim:loadinfo] plugin 'OpenMesh': load succeeded.
[CoppeliaSim:loadinfo] plugin 'Qhull': loading...
[CoppeliaSim:loadinfo] plugin 'Qhull': load succeeded.
[CoppeliaSim:loadinfo] plugin 'RML2': loading...
[CoppeliaSim:loadinfo] plugin 'RML2': load succeeded.
[CoppeliaSim:loadinfo] plugin 'ROS': loading...
[CoppeliaSim:error] plugin 'ROS': load failed (could not load). The plugin probably couldn't load dependency libraries. For additional infos, modify the script 'libLoadErrorCheck.sh', run it and inspect the output.
[CoppeliaSim:loadinfo] plugin 'ROS2': loading...
[CoppeliaSim:error] plugin 'ROS2': load failed (could not load). The plugin probably couldn't load dependency libraries. For additional infos, modify the script 'libLoadErrorCheck.sh', run it and inspect the output.
[CoppeliaSim:loadinfo] plugin 'RRS1': loading...
[CoppeliaSim:loadinfo] plugin 'RRS1': load succeeded.
[CoppeliaSim:loadinfo] plugin 'RemoteApi': loading...
[simExtRemoteApi:loadinfo] starting a remote API server on port 19997
[CoppeliaSim:loadinfo] plugin 'RemoteApi': load succeeded.
[CoppeliaSim:loadinfo] plugin 'SDF': loading...
[CoppeliaSim:loadinfo] plugin 'SDF': load succeeded.
[CoppeliaSim:loadinfo] plugin 'SurfRec': loading...
[CoppeliaSim:loadinfo] plugin 'SurfRec': load succeeded.
[CoppeliaSim:loadinfo] plugin 'UI': loading...
[CoppeliaSim:error] plugin 'UI': load failed (could not load). The plugin probably couldn't load dependency libraries. For additional infos, modify the script 'libLoadErrorCheck.sh', run it and inspect the output.
[CoppeliaSim:loadinfo] plugin 'URDF': loading...
[CoppeliaSim:loadinfo] plugin 'URDF': load succeeded.
[CoppeliaSim:loadinfo] plugin 'URLDrop': loading...
[CoppeliaSim:loadinfo] plugin 'URLDrop': load succeeded.
[CoppeliaSim:loadinfo] plugin 'Vision': loading...
[CoppeliaSim:loadinfo] plugin 'Vision': load succeeded.
[CoppeliaSim:loadinfo] plugin 'ZMQ': loading...
[CoppeliaSim:error] plugin 'ZMQ': load failed (could not load). The plugin probably couldn't load dependency libraries. For additional infos, modify the script 'libLoadErrorCheck.sh', run it and inspect the output.
[CoppeliaSim:loadinfo] using the 'Geometric' plugin.
[CoppeliaSim:loadinfo] using the 'IK' plugin.
[ZMQ remote API server@addOnScript:error] zmqRemoteApi: the ZMQ plugin is not available
[ZMQ remote API@addOnScript:error] zmqRemoteApi: the ZMQ plugin is not available

coppelia
Site Admin
Posts: 8974
Joined: 14 Dec 2012, 00:25

Re: Errors with B0 and ZeroMQ add-ons and remote api clients.

Post by coppelia »

Ok, it seems that many plugins could not load. Did you download CoppeliaSim Ubuntu 20.04 on a fresh Ubuntu 21.04 install?

Normally you should not have compatibility problems, however we do not officially support Ubuntu 21.04 (next official platform will be Ubuntu 22.04).

Anything special about your platform?

Try checking what is wrong by editing file libLoadErrorCheck.sh and writing libsimExtZMQ.so instead of libcoppeliaSimLib.so, and run libLoadErrorCheck.sh from the command line and show us the output.

Cheers

ask4jubad
Posts: 11
Joined: 21 Sep 2021, 07:46

Re: Errors with B0 and ZeroMQ add-ons and remote api clients.

Post by ask4jubad »

I suspect the OS too.

But as instructed, this is output on changing libErrorCheck.

jubril@Jubril-Laptop:~/Downloads/CoppeliaSim$ ./libLoadErrorCheck.sh
linux-vdso.so.1 (0x00007fff8e3eb000)
libboost_regex.so.1.71.0 => /home/jubril/Downloads/CoppeliaSim/libboost_regex.so.1.71.0 (0x00007fd229f76000)
libzmq.so.5 => /home/jubril/Downloads/CoppeliaSim/libzmq.so.5 (0x00007fd229cdd000)
libstdc++.so.6 => /lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007fd229aa6000)
libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007fd229a8b000)
libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007fd22989f000)
libicui18n.so.66 => /lib/x86_64-linux-gnu/libicui18n.so.66 (0x00007fd229597000)
libicuuc.so.66 => /lib/x86_64-linux-gnu/libicuuc.so.66 (0x00007fd2293aa000)
libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007fd229388000)
libsodium.so.23 => /lib/x86_64-linux-gnu/libsodium.so.23 (0x00007fd229330000)
libpgm-5.2.so.0 => /home/jubril/Downloads/CoppeliaSim/libpgm-5.2.so.0 (0x00007fd2290e4000)
libnorm.so.1 => /home/jubril/Downloads/CoppeliaSim/libnorm.so.1 (0x00007fd228db4000)
librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007fd228da9000)
libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007fd228c59000)
/lib64/ld-linux-x86-64.so.2 (0x00007fd22a12e000)
libicudata.so.67 => /lib/x86_64-linux-gnu/libicudata.so.67 (0x00007fd227140000)
libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007fd227139000)

coppelia
Site Admin
Posts: 8974
Joined: 14 Dec 2012, 00:25

Re: Errors with B0 and ZeroMQ add-ons and remote api clients.

Post by coppelia »

unfortunately I can't see anything suspect...

Is your installation fresh or modified somehow?

ask4jubad
Posts: 11
Joined: 21 Sep 2021, 07:46

Re: Errors with B0 and ZeroMQ add-ons and remote api clients.

Post by ask4jubad »

Not at all modified.

I am guessing now that it has to do with the OS.

I think that's the only serious change and unfortunately, you don't support that.

coppelia
Site Admin
Posts: 8974
Joined: 14 Dec 2012, 00:25

Re: Errors with B0 and ZeroMQ add-ons and remote api clients.

Post by coppelia »

Please download CoppeliaSim for Ubuntu20 again. It should work now.

Cheers

Post Reply