Issue in running VREP in a cluster

Typically: "How do I... ", "How can I... " questions
Post Reply
Posts: 24
Joined: 15 Mar 2016, 10:38

Issue in running VREP in a cluster

Post by martin »

Hi Coppelia,

I am trying to run VREP in headless mode in a computational cluster and I connot do that, which I deduce are due to the version of Linux installed in the cluster. The cluster version is:
NAME = "Red Hat Enterprise Linux Server"
VERSION = "7.5 (Maipo)"
ID = "rhel"
ID_LIKE = "fedora"
VARIANT = "Server"
VARIANT_ID = "server"
VERSION_ID = "7.5"
I have tried to run the last two versions of VREP that are on the web page for linux (both for ubuntu) obtaining the following results:

Loading the V-REP library ...
Error: could not find or correctly load the V-REP library
qt.qpa.xcb: could not connect to display
qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found.
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, xcb.

Loading the V-REP library ...
Launching V-REP ...

V-REP PLAYER V3.6.2. (rev. 0)
/mnt/netapp2/Home_FT2/home/ulc/ii/mnv/V-REP_PLAYER_V3_6_2_Ubuntu16_04/./ line 33: 7493 Aborted (`core 'generated)" $ dirname / $ appname "" $ {PARAMETERS [@] } "
srun: error: c0910: task 0: Exited with exit code 134 "
Have you got any idea how can I run VREP in that cluster?


Posts: 628
Joined: 09 Sep 2013, 19:28

Re: Issue in running VREP in a cluster

Post by fferri »

Either use Ubuntu or build V-REP from source.

Post Reply