Error: Signal 11 for Coppelia4.0.0 on Ubuntu 18.04

Typically: "How do I... ", "How can I... " questions
Post Reply
xuehonghu
Posts: 14
Joined: 06 Mar 2019, 15:19

Error: Signal 11 for Coppelia4.0.0 on Ubuntu 18.04

Post by xuehonghu » 17 Mar 2020, 15:54

hello, everyone,
I installed the Ubuntu 18.04 version Coppelia on Ubuntu 18.04.
However, when start the program in the terminal "./coppeliaSim.sh". It returned the following error information:
Loading the CoppeliaSim library...
Done!
Launching CoppeliaSim...
lib: 1
lic: 1

CoppeliaSim Edu V4.0.0. (rev. 4)
Using the default Lua library.
Loaded the video compression library.
Add-on script 'simAddOnScript-addOnScriptDemo.lua' was loaded.
Add-on script 'simAddOnScript-b0RemoteApiServer.lua' was loaded.
Add-on script 'simAddOnScript_PyRep.lua' was loaded.
If CoppeliaSim crashes now, try to install libgl1-mesa-dev on your system:
>sudo apt install libgl1-mesa-dev
OpenGL: VMware, Inc., Renderer: SVGA3D; build: RELEASE; LLVM;, Version: 3.3 (Compatibility Profile) Mesa 19.2.8
...did not crash.
Simulator launched.
Plugin 'Geometric': loading...
Plugin 'Geometric': load succeeded.
Plugin 'Assimp': loading...
Plugin 'Assimp': warning: replaced variable 'simAssimp'
Plugin 'Assimp': load succeeded.
Plugin 'BlueZero': loading...
Plugin 'BlueZero': warning: replaced variable 'simB0'
Plugin 'BlueZero': load succeeded.
Plugin 'BubbleRob': loading...
Plugin 'BubbleRob': load succeeded.
Plugin 'Bwf': loading...
Plugin 'Bwf': load succeeded.
Plugin 'CodeEditor': loading...
Plugin 'CodeEditor': load succeeded.
Plugin 'Collada': loading...
Plugin 'Collada': load succeeded.
Plugin 'ConvexDecompose': loading...
Plugin 'ConvexDecompose': load succeeded.
Plugin 'CustomUI': loading...
Plugin 'CustomUI': warning: replaced variable 'simUI'
Plugin 'CustomUI': warning: replaced function 'simUI.insertTableRow@CustomUI'
Plugin 'CustomUI': warning: replaced function 'simUI.removeTableRow@CustomUI'
Plugin 'CustomUI': warning: replaced function 'simUI.insertTableColumn@CustomUI'
Plugin 'CustomUI': warning: replaced function 'simUI.removeTableColumn@CustomUI'
Plugin 'CustomUI': warning: replaced function 'simUI.setScene3DNodeParam@CustomUI'
Plugin 'CustomUI': load succeeded.
Plugin 'DynamicsBullet-2-78': loading...
Plugin 'DynamicsBullet-2-78': load succeeded.
Plugin 'DynamicsBullet-2-83': loading...
Plugin 'DynamicsBullet-2-83': load succeeded.
Plugin 'DynamicsNewton': loading...
Plugin 'DynamicsNewton': load succeeded.
Plugin 'DynamicsOde': loading...
Plugin 'DynamicsOde': load succeeded.
Plugin 'DynamicsVortex': loading...
Tue Mar 17 15:44:45 2020 - ERROR: Compiled with the flag for AVX but not supported by the CPU.


Error: signal 11:

libcoppeliaSim.so(_Z11_segHandleri+0x2b)[0x7f272a2ee0bb]
/lib/x86_64-linux-gnu/libc.so.6(+0x3ef20)[0x7f272e23ef20]
libVxPlatform.so.2019.0(+0x2bba4)[0x7f26eae73ba4]
libVxPlatform.so.2019.0(_ZN2Vx8LogErrorEPKcz+0x9d)[0x7f26eae73fbd]
libVxPlatform.so.2019.0(+0x20b97)[0x7f26eae68b97]
/lib64/ld-linux-x86-64.so.2(+0x10733)[0x7f272f33b733]
/lib64/ld-linux-x86-64.so.2(+0x151ff)[0x7f272f3401ff]
/lib/x86_64-linux-gnu/libc.so.6(_dl_catch_exception+0x6f)[0x7f272e3672df]
/lib64/ld-linux-x86-64.so.2(+0x147ca)[0x7f272f33f7ca]
/lib/x86_64-linux-gnu/libdl.so.2(+0xf96)[0x7f272b5eef96]


How to address that?

coppelia
Site Admin
Posts: 7706
Joined: 14 Dec 2012, 00:25

Re: Error: Signal 11 for Coppelia4.0.0 on Ubuntu 18.04

Post by coppelia » 17 Mar 2020, 17:56

Hello,

not sure about the reason why, but the Vortex plugin is the culprit. Removing libsimExtDynamicsVortex.so should solve the problem of the crash (but you won't be able to use the Vortex engine).

Cheers

xuehonghu
Posts: 14
Joined: 06 Mar 2019, 15:19

Re: Error: Signal 11 for Coppelia4.0.0 on Ubuntu 18.04

Post by xuehonghu » 21 Mar 2020, 10:31

Thanks for the answer! It works. But I wonder if deactivating vortex engine, what kind of function loss will I experience? Will slow down the simulation speed?

coppelia
Site Admin
Posts: 7706
Joined: 14 Dec 2012, 00:25

Re: Error: Signal 11 for Coppelia4.0.0 on Ubuntu 18.04

Post by coppelia » 26 Mar 2020, 08:50

You simply won't be able to use the Vortex engine for dynamics simulations. You'll have to use the Bullet, ODE or Newton engine instead.

Cheers

Post Reply