Manta Robot keeps slightly moving even after disabling it's script.

Typically: "How do I... ", "How can I... " questions
Post Reply
se654321
Posts: 1
Joined: 19 May 2020, 17:08

Manta Robot keeps slightly moving even after disabling it's script.

Post by se654321 »

Hi,
I have two problems that I am not able to find a solution

1. Manta Robot vehicle keeps moving by itself slightly even after disabling it's script. Why is it so? How can i make it stationary?

2. Why the robot wheels appear slightly below my road floor and as soon as simulation starts, the robot jumps up and wheels get aligned to the floor.

Here is my scene file:

https://drive.google.com/open?id=17YKHp ... EX9GsTe0aJ

I am new to vrep, may be this is a simple problem, but i have spent a lot of time on this. Hope someone can help.

Thank you

coppelia
Site Admin
Posts: 7838
Joined: 14 Dec 2012, 00:25

Re: Manta Robot keeps slightly moving even after disabling it's script.

Post by coppelia »

Hello,

your floor has two components: one visible component, and a component used by the physics engines. The two components do not overlap (remove Shape1, which is the road, and you will see that below you have a green shape that is also used by the physics engine as the ground).

Then, your wheels are slightly sliding sideways. This effect can be reduced by switching to another physics engine, or by slightly adjusting the model:
  • select the objects that are used as wheels by the physics engine (i.e. shapes Cylinder20, Cylinder19, Cylinder21 and Cylinder22) and increase a bit the inertia
  • the wheel axes are also slightly rotating. Select joints fl_brake_joint, fr_brake_joint, bl_brake_joint and br_brake_joint and in the joint dynamics properties, check Lock motor when target velocity is zero. When the vehicle is rolling, you should uncheck that setting again for those joints. YOu can do this via sim.setObjectInt32Parameter(jointHandle,sim.jointintparam_velocity_lock,0)
Cheers

Post Reply