why joint L/H limits do not work?

Typically: "How do I... ", "How can I... " questions
Post Reply
JuestinHastings
Posts: 9
Joined: 31 Dec 2020, 07:26

why joint L/H limits do not work?

Post by JuestinHastings »

hi admin
a problem stumped me
I have correctly set the joint low/high limits for motors. But when the simulation started, motors seems to have no limits.
thank you
the capture img as follows
Image
the configuration as follows
Image

JuestinHastings
Posts: 9
Joined: 31 Dec 2020, 07:26

Re: why joint L/H limits do not work?

Post by JuestinHastings »

the joint angle feedback can be observed more clearly in this graph
Image

coppelia
Site Admin
Posts: 8446
Joined: 14 Dec 2012, 00:25

Re: why joint L/H limits do not work?

Post by coppelia »

Hello,

can you post your scene file, so that we can have a look at it? A self-contained, and simplified scene would make things easier.

Cheers

JuestinHastings
Posts: 9
Joined: 31 Dec 2020, 07:26

Re: why joint L/H limits do not work?

Post by JuestinHastings »

thanks for your reply
the scene file has been uploaded to github and the link is as follows
https://github.com/Justin-wushuang/test.git
Best regards

coppelia
Site Admin
Posts: 8446
Joined: 14 Dec 2012, 00:25

Re: why joint L/H limits do not work?

Post by coppelia »

You have modified the properties of the joint. The physics engine properties of the joint, the ODE part. Restore those to default values.

Additionally, increase the masse and inertia of your legs, according to the design considerations 7 & 8. Make sure you also understand the other design considerations on that page.

Cheers

JuestinHastings
Posts: 9
Joined: 31 Dec 2020, 07:26

Re: why joint L/H limits do not work?

Post by JuestinHastings »

thank you very much!
the problem about joint limits has been processed thanks to your precious advices.

Post Reply