Path problem, robot doesn't follow target dummy

Typically: "How do I... ", "How can I... " questions
Post Reply
sumi_boss
Posts: 33
Joined: 21 Sep 2020, 11:44

Path problem, robot doesn't follow target dummy

Post by sumi_boss »

Hello Coppelia

I have a UR5 robot in my scene, attached to a cuboid. I want to control it in IK mode. I made the tip and target dummies, added the tip/target link, the Ik group everything as you explained. All the joints are in inverse kinematics mode, with hybrid operation checked as well. I added a third dummy, the desired position of the robot tip. I wanted to programmatically make a path to that desired position. So I did that, and as the simulation starts a path is created from the target dummy to the desired position dummy. The path is visible as a red line. However, the robot does not move. I can see that the target dummy is moving along the path to the desired position, but the robot itself is not.

Could you give me any idea as to why this is happening, and how to fix it?

Thanks in advance,

Cheers
Last edited by sumi_boss on 22 Jan 2021, 08:56, edited 1 time in total.

codycichosz
Posts: 14
Joined: 06 Dec 2020, 00:39

Re: Path problem, robot doesn't follow target dummy

Post by codycichosz »

Hello sumi_boss,

Check this tutorial and follow the "IK via method 2" section. I recommend adding 2 IK tasks between the tip-target linked dummies for smoother operation of the robot. https://www.coppeliarobotics.com/helpFi ... torial.htm

I currently have a scene built with a UR10 in IK mode by using that link. I had the same issue as you when I first set my scene up. I found that I had the target dummy in a singularity point for the UR10. I would make sure that the target dummy is in the work envelope (a point that the robot tip can reach). To make it easy, place the target dummy directly below the tip (z-direction, about 0.1 m to 0.15 m) and then away from the robot (x or y direction) the same distance and see if that works for you.

If not, try sharing your scene next time,

Cheers,
-Cody

sumi_boss
Posts: 33
Joined: 21 Sep 2020, 11:44

Re: Path problem, robot doesn't follow target dummy

Post by sumi_boss »

Thanks a lot, the link helped! I realized I forgot to select the UR5 robot as the kinematic chain base in Ik group window and it was instead left as 'World'.

Thanks so much, again!
Cheers

Post Reply