A problem about the graph made using legacy remote API

Typically: "How do I... ", "How can I... " questions
Post Reply
SitStudent
Posts: 16
Joined: 05 May 2020, 12:07

A problem about the graph made using legacy remote API

Post by SitStudent »

Hi, I have a problem about the graph made using legacy remote API.

I send data to VREP at regular intervals using python. Since the number of data is determined, the start time and end time is also determined. However, when I make a graph of the model's motion from those data, the time axis of the graph is different from the actual one. In fact, the graph looks as if the data is being compressed.

Is there any way to make the time axis of the graph match the actual one?
For example, an API to specify the execution speed of a simulation.

sincerely,

coppelia
Site Admin
Posts: 8446
Joined: 14 Dec 2012, 00:25

Re: A problem about the graph made using legacy remote API

Post by coppelia »

Hello,

I am not sure I exactly understand what you mean... e.g. "...the time axis of the graph is different from the actual one."
What is the actual graph?

My guess is you have trouble because Matlab and CoppeliaSim run with different times, e.g. real-time vs simulation time.

You have two options:
  • have CoppeliaSim run in real-time mode. There is a toolbar button for that. This is ok, but you still won't have a perfect synchronization between both applications
  • run in synchronous mode, i.e. from Matlab you would manually trigger each and every of CoppeliaSim's simulation step. That way you won't run in real-time mode, but you will be able to run with the same virtual time for both application (knowing that by default one simulation step in CoppeliaSim in 50ms)
Cheers

Post Reply