Page 1 of 1

Can't Fix a Joint

Posted: 29 Mar 2021, 09:10
by SitStudent

First of all, I share my scene as bellow URL and let me explain about that. ... sp=sharing

In this scene, two models exist, mainly, dynamics model and Kinematics model.
Kinematics model is controlled by remote API, and it behaves as like real human behave(namely, like motion capture).
While, dynamics model is controlled by child script with "Whole Base".

So, simulation is started, and dynamics model should behave same as kinematics model posture.
However this scene can't do. I can't fix "Revolute_Joint2" . it seems like not having any torque and force.

Actually, before adding "Cylinder" and "Revolute_Joint2", this scene has no problem, it's normally controlled, but I wanted to controlled dynamics model so that they had more than 1 DoF.

what is this problem?
Thank you as always.


Re: Can't Fix a Joint

Posted: 29 Mar 2021, 09:52
by coppelia

did you try to run your scenes with the Newton engine? you'll get a very different result.
This is because some engines have a difficult time handling connected rigid bodies that have a too large difference in mass or inertia.


Re: Can't Fix a Joint

Posted: 29 Mar 2021, 10:31
by SitStudent
Thank you for your fast reply.

I tried newton engine and I confirmed my simulation is normally running.
However I actually wanted to run this simulation as bellow URL. ... sp=sharing

I tried Newton engine too in this scene, but it's crashed at the same time started simulation.
In bullet v2.78, this simulation is normally running.
This scene includes so many damper-spring so I think this is the cause of that.

Can I fix this?


Re: Can't Fix a Joint

Posted: 29 Mar 2021, 15:24
by coppelia
You can adjust the overall Bullet engine properties, e.g. set the Constraint solving iterations to 500, or adjust the Bullet time step to 0.001


Re: Can't Fix a Joint

Posted: 02 Apr 2021, 10:11
by SitStudent
I tried a conditions exactly you said, and my scene seemed to successfully work but it was very slow.
Can that problem cause incorrect results?

If possible, I want to run my scene on Newton not Bullet because I think Newton seems to run more successful than Bullet.