Turn off update checker, interferes with automated sim runs

Typically: "How do I... ", "How can I... " questions
Post Reply
RobAtLab
Posts: 86
Joined: 10 Jan 2018, 17:49

Turn off update checker, interferes with automated sim runs

Post by RobAtLab »

I need to turn off the automatic update checker as it is causing havoc with my attempts to run sims over nights and weekends. After setting a series of simulations running using (on a linux terminal)

for i in {1..20}; do ../vrep.sh -g70.5 '/home/user/Downloads/V-REP_PRO_EDU_V3_5_0_Linux/scenes/filename.ttt' -s300000 -q ; done ;

I leave it running only to find that ratehr than complete all the 20 sims it has stopped after just a few and spent hours sitting waiting for me to click to ignore the pop-up which announces that a new version is out. I want to update at some point but I'd ratehr just get my series of runs done on the present ersion I have. And I don't want my unattended runs of sims over the nights and weekends stopped by a pop-up which needs human attention to fix it. I haven't noticed a V-REP setting anywhere that stops this automatic checking, and an online search about turning off V-REP updates gives no relevant results. Is there a config file anywhere in V-REP's folder that I could delete or modify so as to prevent this automatic checking? Or any specific rule I could add to a linux ubuntu ufw firewall to block V-REP's ability to check against your online servers whether a new version is available? I'm desperate for help with this, having my runs paused awaiting a human click makes gathering statistical data impossible.
Thank you

Would editing the 8 byte file updtChck.data perhaps help? I'm guessing it has something to do with deciding at what tiems of day to check for updates?

fferri
Posts: 681
Joined: 09 Sep 2013, 19:28

Re: Turn off update checker, interferes with automated sim runs

Post by fferri »

Hello,

have you tried setting doNotShowUpdateCheckMessage = true in system/usrset.txt?

Or even better for this scenario, set suppressStartupDialogs = true.

RobAtLab
Posts: 86
Joined: 10 Jan 2018, 17:49

Re: Turn off update checker, interferes with automated sim runs

Post by RobAtLab »

Thanks fferri, that looks like an appropriate solution for my trouble. I've edited doNotShowUpdateCheckMessage in the usrset.txt file from false to true but can't find "suppressStartupDialogs = false" anywhere so as to change it to being true, should I just add that line in, set to true, at the bottom of the file? Thanks.

coppelia
Site Admin
Posts: 8223
Joined: 14 Dec 2012, 00:25

Re: Turn off update checker, interferes with automated sim runs

Post by coppelia »

Hello,

suppressStartupDialogs was recently added. If you are running V3.6.2, then it will make it into the next release. Otherwise, try upgrading to the latest release.

Cheers

Post Reply