Black screen on Coppelia startup

Report crashes, strange behaviour, or apparent bugs
Post Reply
biiigwang777
Posts: 4
Joined: 16 Sep 2022, 07:33

Black screen on Coppelia startup

Post by biiigwang777 »

When i start the new version of coppelia from my ubuntu20.04(WSL2) terminal with ./coppeliaSim.sh a black screen fills the scene area and i cannot see my scenes when i open them and cant therefore run my simulations. Cannot open new scenes or get anything in the scene besides the black screen.
Image
CPU:12th Gen Intel(R) Core(TM) i7-12700
GPU(Integrated graphics):Intel(R) UHD Graphics 770

Code: Select all

[CoppeliaSimClient]    loading the CoppeliaSim library...
[CoppeliaSimClient]    done.
[CoppeliaSimClient:loadinfo]   launching CoppeliaSim...
[CoppeliaSim:loadinfo]   CoppeliaSim V4.3.0., (rev. 3), flavor: 1
[CoppeliaSim:loadinfo]   Legacy machine ID: 9447-C1EB-F0FB-8C8E-F7E3-9F0D
[CoppeliaSim:loadinfo]   Machine ID: D856-7372-C43A-0000-08EC-0101
[CoppeliaSim:loadinfo]   loaded the video compression library.
[CoppeliaSim:loadinfo]   if CoppeliaSim crashes now, try to install libgl1-mesa-dev on your system:
    >sudo apt install libgl1-mesa-dev
[CoppeliaSim:loadinfo]   OpenGL: Microsoft Corporation, Renderer: D3D12 (Intel(R) UHD Graphics 770), Version: 3.1 Mesa 21.2.6
[CoppeliaSim:loadinfo]   simulator launched.
[CoppeliaSim:loadinfo]   plugin 'Assimp': loading...
[CoppeliaSim:loadinfo]   plugin 'Assimp': load succeeded.
[CoppeliaSim:loadinfo]   plugin 'B0': loading...
[CoppeliaSim:loadinfo]   plugin 'B0': load succeeded.
[CoppeliaSim:loadinfo]   plugin 'BWF': loading...
[CoppeliaSim:loadinfo]   plugin 'BWF': load succeeded.
[CoppeliaSim:loadinfo]   plugin 'BubbleRob': loading...
[CoppeliaSim:loadinfo]   plugin 'BubbleRob': load succeeded.
[CoppeliaSim:loadinfo]   plugin 'Bullet-2-78': loading...
[CoppeliaSim:loadinfo]   plugin 'Bullet-2-78': load succeeded.
[CoppeliaSim:loadinfo]   plugin 'Bullet-2-83': loading...
[CoppeliaSim:loadinfo]   plugin 'Bullet-2-83': load succeeded.
[CoppeliaSim:loadinfo]   plugin 'CodeEditor': loading...
[CoppeliaSim:loadinfo]   plugin 'CodeEditor': load succeeded.
[CoppeliaSim:loadinfo]   plugin 'ConvexDecompose': loading...
[CoppeliaSim:loadinfo]   plugin 'ConvexDecompose': load succeeded.
[CoppeliaSim:loadinfo]   plugin 'Eigen': loading...
[CoppeliaSim:loadinfo]   plugin 'Eigen': load succeeded.
[CoppeliaSim:loadinfo]   plugin 'ExternalRenderer': loading...
[CoppeliaSim:loadinfo]   plugin 'ExternalRenderer': load succeeded.
[CoppeliaSim:loadinfo]   plugin 'GLTF': loading...
[CoppeliaSim:loadinfo]   plugin 'GLTF': load succeeded.
[CoppeliaSim:loadinfo]   plugin 'Geom': loading...
[CoppeliaSim:loadinfo]   plugin 'Geom': load succeeded.
[CoppeliaSim:loadinfo]   plugin 'ICP': loading...
[CoppeliaSim:loadinfo]   plugin 'ICP': load succeeded.
[CoppeliaSim:loadinfo]   plugin 'IGL': loading...
[CoppeliaSim:loadinfo]   plugin 'IGL': load succeeded.
[CoppeliaSim:loadinfo]   plugin 'IK': loading...
[CoppeliaSim:loadinfo]   plugin 'IK': load succeeded.
[CoppeliaSim:loadinfo]   plugin 'IM': loading...
[CoppeliaSim:loadinfo]   plugin 'IM': load succeeded.
[CoppeliaSim:loadinfo]   plugin 'K3': loading...
[CoppeliaSim:loadinfo]   plugin 'K3': load succeeded.
[CoppeliaSim:loadinfo]   plugin 'LuaCmd': loading...
[CoppeliaSim:loadinfo]   plugin 'LuaCmd': load succeeded.
[CoppeliaSim:loadinfo]   plugin 'MTB': loading...
[CoppeliaSim:loadinfo]   plugin 'MTB': load succeeded.
[CoppeliaSim:loadinfo]   plugin 'Newton': loading...
[CoppeliaSim:loadinfo]   plugin 'Newton': load succeeded.
[CoppeliaSim:loadinfo]   plugin 'ODE': loading...
[CoppeliaSim:loadinfo]   plugin 'ODE': load succeeded.
[CoppeliaSim:loadinfo]   plugin 'OMPL': loading...
[CoppeliaSim:loadinfo]   plugin 'OMPL': load succeeded.
[CoppeliaSim:loadinfo]   plugin 'OpenGL3Renderer': loading...
[CoppeliaSim:loadinfo]   plugin 'OpenGL3Renderer': load succeeded.
[CoppeliaSim:loadinfo]   plugin 'OpenMesh': loading...
[CoppeliaSim:loadinfo]   plugin 'OpenMesh': load succeeded.
[CoppeliaSim:loadinfo]   plugin 'QML': loading...
[CoppeliaSim:loadinfo]   plugin 'QML': load succeeded.
[CoppeliaSim:loadinfo]   plugin 'Qhull': loading...
[CoppeliaSim:loadinfo]   plugin 'Qhull': load succeeded.
[CoppeliaSim:loadinfo]   plugin 'RML2': loading...
[CoppeliaSim:loadinfo]   plugin 'RML2': load succeeded.
[CoppeliaSim:loadinfo]   plugin 'ROS': loading...
[CoppeliaSim:error]   plugin 'ROS': load failed (could not load). The plugin probably couldn't load dependency libraries. For additional infos, modify the script 'libLoadErrorCheck.sh', run it and inspect the output.
[CoppeliaSim:loadinfo]   plugin 'ROS2': loading...
[CoppeliaSim:loadinfo]   plugin 'ROS2': load succeeded.
[CoppeliaSim:loadinfo]   plugin 'RRS1': loading...
[CoppeliaSim:loadinfo]   plugin 'RRS1': load succeeded.
[CoppeliaSim:loadinfo]   plugin 'RemoteApi': loading...
[simExtRemoteApi:loadinfo]   starting a remote API server on port 19997
[CoppeliaSim:loadinfo]   plugin 'RemoteApi': load succeeded.
[CoppeliaSim:loadinfo]   plugin 'Ruckig': loading...
[CoppeliaSim:loadinfo]   plugin 'Ruckig': load succeeded.
[CoppeliaSim:loadinfo]   plugin 'SDF': loading...
[CoppeliaSim:loadinfo]   plugin 'SDF': load succeeded.
[CoppeliaSim:loadinfo]   plugin 'Subprocess': loading...
[CoppeliaSim:loadinfo]   plugin 'Subprocess': load succeeded.
[CoppeliaSim:loadinfo]   plugin 'SurfRec': loading...
[CoppeliaSim:loadinfo]   plugin 'SurfRec': load succeeded.
[CoppeliaSim:loadinfo]   plugin 'UI': loading...
[CoppeliaSim:loadinfo]   plugin 'UI': load succeeded.
[CoppeliaSim:loadinfo]   plugin 'URDF': loading...
[CoppeliaSim:loadinfo]   plugin 'URDF': load succeeded.
[CoppeliaSim:loadinfo]   plugin 'URLDrop': loading...
[CoppeliaSim:loadinfo]   plugin 'URLDrop': load succeeded.
[CoppeliaSim:loadinfo]   plugin 'Vision': loading...
[CoppeliaSim:loadinfo]   plugin 'Vision': load succeeded.
[CoppeliaSim:loadinfo]   plugin 'WS': loading...
[CoppeliaSim:loadinfo]   plugin 'WS': load succeeded.
[CoppeliaSim:loadinfo]   plugin 'ZMQ': loading...
[CoppeliaSim:loadinfo]   plugin 'ZMQ': load succeeded.
[CoppeliaSim:loadinfo]   using the 'Geometric' plugin.
[CoppeliaSim:loadinfo]   using the 'IK' plugin.

coppelia
Site Admin
Posts: 9551
Joined: 14 Dec 2012, 00:25

Re: Black screen on Coppelia startup

Post by coppelia »

Hello,

does it run fine on a regular Ubuntu machine? From what I know, GUI support for WSL is less than 2-3 weeks old. We haven't tried yet either..

[Edit] I just tried and it seems to be working fine on Win11 with Nvidia drivers and Ubuntu 20.04 guest. Did you follow the instructions correctly for installing the GUI support on WSL?

Cheers

biiigwang777
Posts: 4
Joined: 16 Sep 2022, 07:33

Re: Black screen on Coppelia startup

Post by biiigwang777 »

Thank you for your reply!🌷

I think I have configured it according to the instructions. This WSL2 can run other GUI APPs normally. Other UI components of coppeliaSim can also work normally. Only the "scene" window is blank.

Since June this year, I have been able to run CoppeliaSim on WSL2 on another laptop, which has performed very well. So far, I have not encountered any problems. (CPU:AMD Ryzen 7 5700U with Radeon Graphics;Ubuntu20.04)

It is estimated that GUI support has adaptation problems on different CPUs🤷‍♂️.
coppelia wrote: 16 Sep 2022, 13:41 Hello,

does it run fine on a regular Ubuntu machine? From what I know, GUI support for WSL is less than 2-3 weeks old. We haven't tried yet either..

[Edit] I just tried and it seems to be working fine on Win11 with Nvidia drivers and Ubuntu 20.04 guest. Did you follow the instructions correctly for installing the GUI support on WSL?

Cheers

coppelia
Site Admin
Posts: 9551
Joined: 14 Dec 2012, 00:25

Re: Black screen on Coppelia startup

Post by coppelia »

When you say that you can run other GUI apps normally, are those apps OpenGL-based? See, the black screen you have is the OpenGL part, but the rest of the GUI displays fine (non-OpenGL). Try with another OpenGL app and see if that displays fine.

Cheers

Valenorf
Posts: 12
Joined: 10 May 2017, 21:35

Re: Black screen on Coppelia startup

Post by Valenorf »

this is a known problem even for gazebo/rviz

https://github.com/microsoft/wslg/issues/455

It only affect intel GPU, and most likely it seems need a fix on the driver side. You can use software rendering in the meantime (there is a command to enable it, but I don't remember it)

biiigwang777
Posts: 4
Joined: 16 Sep 2022, 07:33

Re: Black screen on Coppelia startup

Post by biiigwang777 »

coppelia wrote: 19 Sep 2022, 06:18 When you say that you can run other GUI apps normally, are those apps OpenGL-based? See, the black screen you have is the OpenGL part, but the rest of the GUI displays fine (non-OpenGL). Try with another OpenGL app and see if that displays fine.

Cheers
Thanks for answering🍻

biiigwang777
Posts: 4
Joined: 16 Sep 2022, 07:33

Re: Black screen on Coppelia startup

Post by biiigwang777 »

Valenorf wrote: 19 Sep 2022, 13:22 this is a known problem even for gazebo/rviz

https://github.com/microsoft/wslg/issues/455

It only affect intel GPU, and most likely it seems need a fix on the driver side. You can use software rendering in the meantime (there is a command to enable it, but I don't remember it)
LOL,Thank you, friend🤝

Post Reply