coppeliaSim.sh not working

Report crashes, strange behaviour, or apparent bugs
Post Reply
sbob25
Posts: 2
Joined: 22 Feb 2024, 08:50

coppeliaSim.sh not working

Post by sbob25 »

Hi.

Enviroment : Ubuntu20.04 LTS, WSL2 in windows 10, CoppeliaSim_Edu_V4_1_0_Ubuntu20_04

When I executed ./coppeliaSim.sh in WSL2
I got the following error messages:


Error: signal 11:

/home/user/CoppeliaSim_Edu_V4_1_0_Ubuntu20_04/libcoppeliaSim.so(_Z11_segHandleri+0x30)[0x7f08920f2ae0]
/lib/x86_64-linux-gnu/libc.so.6(+0x43090)[0x7f0894ffa090]
/lib/x86_64-linux-gnu/libc.so.6(+0x1886e5)[0x7f089513f6e5]
/home/user/CoppeliaSim_Edu_V4_1_0_Ubuntu20_04/libcoppeliaSim.so(_Z15initGl_ifNeededv+0x11c)[0x7f0892298cac]
/home/user/CoppeliaSim_Edu_V4_1_0_Ubuntu20_04/libcoppeliaSim.so(_ZN11CMainWindowC2Ev+0x61d)[0x7f089257190d]
/home/user/CoppeliaSim_Edu_V4_1_0_Ubuntu20_04/libcoppeliaSim.so(_ZN3App16createMainWindowEv+0x71)[0x7f0892289531]
/home/user/CoppeliaSim_Edu_V4_1_0_Ubuntu20_04/libcoppeliaSim.so(_Z24simRunSimulator_internalPKciPFvvES2_S2_iS0_b+0x475)[0x7f0892107fe5]
/home/user/CoppeliaSim_Edu_V4_1_0_Ubuntu20_04/libcoppeliaSim.so(simRunSimulatorEx+0x13)[0x7f08920f0493]
/home/user/CoppeliaSim_Edu_V4_1_0_Ubuntu20_04/coppeliaSim(+0x2ad6)[0x55d0440e6ad6]
/home/user/CoppeliaSim_Edu_V4_1_0_Ubuntu20_04/coppeliaSim(+0x251c)[0x55d0440e651c]


I already tried "sudo apt install libgl1-mesa-dev"
But it's still not working.
Anotherthing I tried was running it headless "./coppeliaSim.sh -h". And It works well.
How can I fix this error?

Thanks in advance for your reply.

fferri
Posts: 1217
Joined: 09 Sep 2013, 19:28

Re: coppeliaSim.sh not working

Post by fferri »

If you search old forum posts you should find someone that eventually succeeded in running under WSL....

sbob25
Posts: 2
Joined: 22 Feb 2024, 08:50

Re: coppeliaSim.sh not working

Post by sbob25 »

Thanks for your reply.
I reinstalled WSL2. And finally succeeded in running coppeliasim!

Post Reply