Model folder not found on iMac

Report crashes, strange behaviour, or apparent bugs
Post Reply
Posts: 1
Joined: 14 Aug 2018, 06:07

Model folder not found on iMac

Post by joebataz »


I am new to v-rep as a tool being used for a robotics class. I originally downloaded, extracted and ran v-rep 3.50 rev 4 on an iMac using Sierra. I was able to load scenes, run simulations and see all the robot models. That was about 3 weeks ago. I ran it a couple of more times early on but stopped running it until a day or so ago.
I got an error message that said the following:

The model folder was not found. If the model folder is present in the V-REP folder, then it might be that your system has automatically added attributes to all V-REP files, causing problems. Try running from a terminal
sudo xattr -r -d *
in the V-REP folder to strip away those attributes, otherwise you might experiences strange behaviours and crashes.

I did this and no change. I joined this forum and started searching for solutions. I found a few threads and went thru the suggestions presented and still no luck. I removed the software, reinstalled at the desktop and ran into the same issue.That is where I am at. I can load scenes and models but the dropdown in the file open dialog gives default file locations as being in /private/var/folders/95/ and what looks like windows objects designators. I tried without success to change the default location for folders to the correct location (???) inside the usrset.txt file which I also manually created from the information inside some of the thread. Again it continues to point to the private locations.
And of course this is now happening when I actually have tasks I need to do with the software for classes. I would greatly appreciate any help anyone might give me to get this fixed. Being a procrastinator I see the due wire approaching rapidly.

Thanks again,


Posts: 598
Joined: 09 Sep 2013, 19:28

Re: Model folder not found on iMac

Post by fferri »

If the app's default dir shows as /provate/var/folders/... it means the app is running in App Translocation.

From ... ation.html:
Under what circumstances does App Translocation occur? First, the app must have a extended attribute. If you delete the quarantine xattr, then App Translocation does not occur, and the app will launch from where it was unarchived, like normal.
So, it is very likely that some error occurred and you didn't remove the quarantine attribute.

Post Reply