V-rep 3.6.2 doesn't work in Ubuntu 18.04 LTS

Typically: "How do I... ", "How can I... " questions
Post Reply
xuehonghu
Posts: 14
Joined: 06 Mar 2019, 15:19

V-rep 3.6.2 doesn't work in Ubuntu 18.04 LTS

Post by xuehonghu »

Hey, I am trying to open vrep.sh by typing "./vrep.sh" in command line, finally, it first shows some successful loading of plugins, and also prompt of the v-rep window jumps out. But suddenly it closes and says "./vrep.sh : line 33 6396 Illegal instruction (core dumped) "$dirname/$appname" "${PARAMETERS[@]}"

However, V-rep 3.6.1 works well, can anyone show me how to let 3.6.2 function properly?

coppelia
Site Admin
Posts: 7838
Joined: 14 Dec 2012, 00:25

Re: V-rep 3.6.2 doesn't work in Ubuntu 18.04 LTS

Post by coppelia »

Hello,

can you tell me what the console says just before crashing? Is one plugin the culprit maybe?
You can find out by removing the plugin from the V-REP folder and trying again.

Cheers

benzr
Posts: 1
Joined: 28 Oct 2019, 11:14

Re: V-rep 3.6.2 doesn't work in Ubuntu 18.04 LTS

Post by benzr »

Hi,
I got the same issue when moving to VREP 3.6.2 on Ubuntu 18.04 LTS.
"vrep.sh" crashes at the last line ("$dirname/$appname" "${PARAMETERS[@]}") corresponding to thee execution of the vrep executable.
The log of vrep execution is the following :
Loading the V-REP library...
Done!
Launching V-REP...

V-REP PRO EDU V3.6.2. (rev. 0)
Using the default Lua library.
Loaded the video compression library.
Add-on script 'vrepAddOnScript-addOnScriptDemo.lua' was loaded.
Add-on script 'vrepAddOnScript-b0RemoteApiServer.lua' was loaded.
Add-on script 'vrepAddOnScript_PyRep.lua' was loaded.
If V-REP crashes now, try to install libgl1-mesa-dev on your system:
>sudo apt install libgl1-mesa-dev
OpenGL: NVIDIA Corporation, Renderer: Quadro FX 5800/PCIe/SSE2, Version: 3.3.0 NVIDIA 340.107
...did not crash.
Simulator launched.
Plugin 'MeshCalc': loading...
Plugin 'MeshCalc': load succeeded.
Plugin 'Assimp': loading...
Plugin 'Assimp': warning: replaced variable 'simAssimp'
Plugin 'Assimp': load succeeded.
Plugin 'BlueZero': loading...
Plugin 'BlueZero': warning: replaced variable 'simB0'
Plugin 'BlueZero': load succeeded.
Plugin 'BubbleRob': loading...
Plugin 'BubbleRob': load succeeded.
Plugin 'Bwf': loading...
Plugin 'Bwf': load succeeded.
Plugin 'CodeEditor': loading...
Plugin 'CodeEditor': load succeeded.
Plugin 'Collada': loading...
Plugin 'Collada': load succeeded.
Plugin 'ConvexDecompose': loading...
Plugin 'ConvexDecompose': load succeeded.
Plugin 'CustomUI': loading...
Plugin 'CustomUI': warning: replaced variable 'simUI'
Plugin 'CustomUI': warning: replaced function 'simUI.insertTableRow@CustomUI'
Plugin 'CustomUI': warning: replaced function 'simUI.removeTableRow@CustomUI'
Plugin 'CustomUI': warning: replaced function 'simUI.insertTableColumn@CustomUI'
Plugin 'CustomUI': warning: replaced function 'simUI.removeTableColumn@CustomUI'
Plugin 'CustomUI': warning: replaced function 'simUI.setScene3DNodeParam@CustomUI'
Plugin 'CustomUI': load succeeded.
Plugin 'DynamicsBullet-2-78': loading...
Plugin 'DynamicsBullet-2-78': load succeeded.
Plugin 'DynamicsBullet-2-83': loading...
Plugin 'DynamicsBullet-2-83': load succeeded.
Plugin 'DynamicsNewton': loading...
Plugin 'DynamicsNewton': load succeeded.
Plugin 'DynamicsOde': loading...
Plugin 'DynamicsOde': load succeeded.
Plugin 'DynamicsVortex': loading...
Illegal instruction (core dumped)


vrep executable seems to crash when loading "DynamicsVortex" plugin
If you do not use the Vortex plugin , a possible workaround is to prevent the loading of the plugin (e.g. by renaming it)
mv libv_repExtDynamicsVortex.so to_libv_repExtDynamicsVortex.so
This does not solve the problem if you use Vortex but for other solvers (Bullet, Ode and Newton) it seems to work fine.
KInd regards

coppelia
Site Admin
Posts: 7838
Joined: 14 Dec 2012, 00:25

Re: V-rep 3.6.2 doesn't work in Ubuntu 18.04 LTS

Post by coppelia »

Thanks for the info.

Cheers

Post Reply